New Vero 4K+ not working - DOA?

I bought a Vero 4k+ a week ago and today I unpacked it & set it up. On plugging the power adapter in, the LED cross lights up red for 5 seconds and then goes out. There is nothing on the screen and I have checked the power adapter which seems OK since there’s 5.36 volts DC off-load on the plug.

Could this be a DOA unit?


  • Double-check the HDMI cable is pushed in at both ends.
  • Try another HDMI cable if you have one.

It’s unlikely there’s a problem with the unit itself as it would’ve been tested prior to shipping.

I have tried a brand new cable I happened to have but the TV still reports ‘no signal’. But the instruction booklet does say the LED should turn blue while the system boots but at no point does it light up blue, just solid red for 5 seconds.

Vero 4k + doesn’t have a blue light any more so that is expected.

The Vero 4K + has no blue LED
If the device boots successfully the red light should go out after a couple of seconds.

Some suggestions:

Do you have another power supply that’s 5V, 2A? Feel free to take a picture if unsure

What’s the make and model of display you’re connecting to?


I connected it to an oldish LG Flatron M2294D TV (tried both HDMI inputs) but I’ve since connected it to a Viewsonic monitor and I’m pleased to say it does work. I’ll just have to get a decent monitor now.

(I bought the Vero to use with the LG TV in my bedroom - I’m a systems admin with several hundred servers to look after and I wanted to be able to wake up in the morning, put the TV on via the remote and use a browser on the Vero to see at a glance what systems had gone wrong during the night before deciding whether to get out of bed or not).

Problem solved Thanks!

Your M2294 has a 1680x1050 resolution which is not a HDMI standard. ATM, Vero doesn’t support non-standard modes, but if you could send us the EDID it might be interesting exercise to see if we can make it work.

On the vero, you can grab the EDID with

cat /sys/class/hdmitx/hdmitx0/rawedid

Vero doesn’t come with a browser but there are solutions available.

As a final update, I unplugged the power to the TV, plugged it back in and the HDMI inputs now work! It’s been on standby for years so I guess a TV reboot was needed. But I will get a better screen anyway since this TV is 720p only.

1 Like

As a guess, I would say that you turned on the Vero before the TV.

If we don’t get an EDID we default to 1080p on 4K +

This would give you no signal. I can give some instructions on how to change the default fallback to 720p if you’d like


Reading up, it seems the thing should accept a 1080p input. But it’s 16:10 so is never going to be as good as a full HD screen.

Just for your reference, as I’m now back at my desk, you can do:

sudo fw_setenv hdmimode 720p50hzforce
sudo fw_setenv outputmode 720p50hzforce

Then it won’t matter what order Vero is started in.

If I reboot the Vero with the TV switched on, the empty folder /sys/class/hdmirx is then created but there’s no …/hdmitx subtree. Not to worry, I’ll get a better screen for this application.

Thanks for your help,


That’s weird!

Can you run:

dmesg | paste-log when this happens and send us the URL?

Oops typos

Ah – it should be amhdmitx

cat /sys/class/amhdmitx/amhdmitx0/rawedid

This info is at

The output of my dmesg is at

Thank you. It should have worked from the get-go but you could have issues with a 1080p resolution because we default to 10 bits. Although the screen says it handles 10 bits, it won’t be able to do that at 1080p.

Just FYI.