New Vero 4k - Recurrence of old image artifact issue

Hi Folks,

Received my vero 4k a couple of days ago, really happy with it… well done for creating such a great little device :smile:

It took me a little while to get set up. I’m using default settings, and did a system update when I unpacked it and have found that I’m seeing an old issue reported in the two threads below from 2015 & 2017.

  1. Coloured Artifact on Right Edge of Art - #2 by mark888
  2. Problem with TV Show poster image, strange error.

Specifically i’m seeing much the same issue with the artifact on the right hand edge of the artwork in the list view.

Some notes:

  • I’m outputting1920x1080 to a 4k tv which is showing a non upscaled 1920x1080 resolution.
  • It isn’t consistent between images as I can enter the tv shows view and see it for one show, exit, and go straight back in and the artwork is displaying correctly for the same show.
  • The artifact seems to be either (1) garbage, or (2) the underlap of a previous piece of artwork
  • It is showing on all views but is more noticeable on the list view.
  • I am viewing a source folder using the tv show view, but it is also noticeable in the movie view but a lot less so.
  • If I look for an alternative artwork online to replace it with, then that newly added artwork will display correctly but later will start showing the artifact.

I’ve attached an image below showing it up close to help give an idea of what it looks like.

Interestingly, all the artwork appears to display fine after a reboot, but then seems to start showing the artifact randomly throughout the list after you change any show’s artwork to something new. I haven’t been able to test enough to confirm this though

@sam_nazarko asked for a heads up in one of the earlier threads if it showed up in the new skin, hence this post.

Happy to help investigate since it happens fairly reliably on a new vanilla vero 4k.

Any ideas what might be causing this?

Thanks much :slight_smile:

Not sure, your picture has to be rotated clockwise 90°?

Hi, yes image is rotated 90 degrees.

I tried to rotate and upload again but it’s not cooperating (posting from mobile).

I wanted to give a closer image of the artifacting than the previous two threads.

This is a strange one. The topic you linked to is regarding the Pi, so I wouldn’t expect to see this on Vero 4K.

Can you post some debug logs?


Hi @sam_nazarko, as requested i’ve uploaded some debug logs into the official osmc pastebin. You can find them at:

At the bottom you can see that I have moved down a few items in the list and for each image being shown I am getting the following error:

DEBUG: ffmpeg[E52FF300]: [swscaler] No accelerated colorspace conversion found from yuv420p to bgra. 

Could this be the cause, I have tailed the debug logs as I move up and down the list while waiting for the artifact to appear. I receive the above error regardless of the presence of the artifact.

Also, I was wondering if it may be related to one of the recommended plugins that I installed soon after getting the box up and running. I uninstalled the “skin helper service” and could then reliably see the artifact on every single image.

When I reinstalled the skin helper service it became hit and miss as to whether the artifact would show up but give enough moving up and down the list it appears sooner or later.

Interestingly, on the images where the artifact doesn’t appear the images seem to flicker on the right hand side where the artifact would be. There is usually a black vertical line there.

I also note the following error which might be unrelated.

18:09:05.693 T:3878679296 WARNING: CSkinInfo: failed to load skin settings

Finally, I switched over to the default kodi estuary skin and the artifact was visible there also.

Question - Would a reinstall of OSMC back to its default settings be helpful? I’m not opposed to it as i’ve already backed up everything, but not sure what is different as i’ve not really changed much since setting it up a couple of days ago.

Thanks :smiley:

Bumping the thread.

Do any other folks have any ideas what could be causing this?

I’m keen to help find and fix the issue.

If you want to help, you can test a quick thing:

  1. ssh into your Vero, osmc/osmc
  2. cd /usr/share/kodi/addons/skin.osmc/16x9
  3. cp ViewType53.xml ViewType53.xml.old
  4. change in xml section <include name="image-53"> line
  5. sudo systemctl restart mediacenter

Now, test whether it’s gone and provide your result. Whether this is a possible solution or the scaling code in the mediacenter has to be touched, will be discussed by the developers, later.

Hi @JimKnopf,

Just to make sure i’m testing as intended, which of the viewtypes (list/wall/wide) corresponds to viewtype53 ?


edit - Looking up close at the right hand edge of the artwork there does appear to be about four pixels or so that when not showing as a multicolored artifact appear as a black line. It looks like the line is always there, but only the “colour” varies.

Does the theme attempt to place a shadow on the artwork?


Hi @JimKnopf, I made the change as requested. First I set as 198 and then tried 198\ verbatim as above.

In both cases I note that the artifact still displays.

In addition I now find that i’m unable to take screenshots to upload as per:

The screenshot directory is set as the osmc home directory and debug is on. The command reports as successful but no screenshot is created.

I am wondering if there isn’t something wrong with the installation of osmc on this particular vero 4k… is a reinstall back to its default state likely to help with things any?

I am currently running (according to uname -a)

Linux osmc 3.14.29-69-osmc #1 SMP Sat Mar 17 16:13:39 UTC 2018 aarch64 GNU/Linux

The device is running well but first the image artifact glitch and now the screenshot command not working make me wonder.

@sam_nazarko, do you have any advice as to how I can get screenshots working to provide you with more information? Or anything else I can provide? Somewhat concerned about these issues occuring out of the box on a new device.

Thanks folks :slight_smile:

Sorry, the backslash after 198 was a typo, I corrected that. So, if you still see the issue in list mode after mediacenter restart or a reboot, I’m out of ideas for the moment.

No problems, I appreciate the help.

Update - Switching from the osmc / estuary skins to arctic zephyr seems to have solved this for now.

Not sure what has caused it but the skin switch seems to have sorted it for now :smiley:

Thanks folks!