New Vero 4K / slow network performance

oh, sorry, it didtn work when enabling it through web interface. here again:



I maybe wrong, but to set this up the way I think you want to is to change the video source in kodi to:

root file system, mnt then select the Media Folder. Then update your path substitute in advancedsettings.xml to:


Thanks Tom.


ah ok, and then the database is untouched and there are still the smb:// entries used?


Should be, make the changes and restart kodi.

Thanks Tom.

yeah… that wasnt that good. i changed the substitution as you said and added the /mnt source in kodi and deleted the smb source…
now with the next rescan of the library i have two entries of any movie. not just in kodi but also in the database… really bad

how do i know from which source it is playing now? i actually deleted the smb source, but maybe the credentials are still cached and its still using the smb path, altought i added the mnt path…


Please provide new logs.

What is the video source path set as on the other kodi devices?

If you’ve deleted the smb source, it can only be playing the fstab source.

Thanks Tom.

nice log link ^^

but after a few tries it worked…

so here are the logs… now while i have two entries of the movies i started the playback of the first entry of “bad moms”. i can see in the logs its playing from smb://, although i deleted this source and now only have the /mnt as video source. probably the credentials are cached.
then i started the second entry for bad moms. its playing from /mnt/
so its not working like expected.

in other kodis i have set the video source path to smb:// as i am also using windows based kodis. so it should simply load the smb:// path from the mysql library and replacing it with /mnt…

Indeed so. Let’s look at what you wrote:

so it should simply load the smb:// path from the mysql library

that’s the “from” part of the path substitution

and replacing it with /mnt…

that’s the “to” part of the path substitution.

Your path substitution is this way:


Rather than me copy what has already been written, take a look at this post, which concisely explains what you need to do next.


i had it the other way around, but then Tom_Doyle told me to change it. so now i tried both versions. but both does not work.
i now have from smb to mnt again.
and i deleted all sources and added the mnt one.

BUT when clicking on a movie it doesnt show the movie information anymore (althothough its configurated to do that and it worked before i changed the paths) and it does not show the actors anymore. when i add the smb source again it worked. and again, when i am starting library scanning duplicate entries. also in the database of course (see picture) (they are deleted when i am deleting the source).

and i am still not able (due to limited skill) to check if its playing through mnt now. i guess its still using the smb path (because logs say: “VideoPlayer: Opening: smb://…”) with cached credentials.

here are the logs:

You must only scan from one machine. In your case, you should choose one of the Windows-based Kodi machines.

In the post I linked to it says:

Did you do that?

Yes I scanned from the window machine as in the article you linked. But it didn’t say I am not allowed to scan from the other machine (Vero with mnt path)
Would be bad because I need to start my computer for scanning movies everytime.

But than i wouldn’t have double entries, but movie information still does not show when i click on a movie and also no actor information.

Well easy solution, scan from the Vero and use path substitution on the Windows machine.
The only thing is not to scan from both

I scan from both, but use the kodi nfs paths within kodi itself and use only pathsubstitution on my Vero to /mnt
That way kodi puts the kodi nfs paths in mysql db, so it can be used by all other devices.

@fzinken yes could do that, but then I need to change all database entries to mnt as I want to keep my watchstates. And I need to configure all other Kodis (5) instead of one :wink:
But would be an option.

@Theetjuh sorry I don’t get it … you mean you scan from both also from Vero which has mnt as source and it writes the entries with nfs in the database? Can you share your config? NFS or smb should be the same in this situation, right?

One of my source items from sources.xml:

    <path pathversion="1">nfs://</path>

One of my pathsubstitutions in advancedsettings.xml


Hope that helps you abit, this keeps my files in the mysql db with nfs:// so all other devices use that, but on my vero with path-substitution it translates to /mnt.

ah ok, so you added nfs as source in vero (for me it would be smb) but then you replace the path with path substitution to /mnt. so when you are scanning the entries are right, because path substition doesnt work then, only for playback, right?
and you dont add /mnt as source in kodi at vero, right?

how do you make sure (or check) its really using the mnt path?

regards and thanks for your help! =)

You got it exactly right!

I got no idea anymore how I tested, I think with a typo in the path substitution so it throws an error, correct it and it works.

thanks to all. its working now.
substitution from smb to mnt
and added smb source in kodi, not the mnt source. that way no double entries and i can update my library.
i check it by unmounting the share in the filesystem… kodi wasnt able to play the movie… then mounted it again via fstab file and its working… so i am pretty sure its using the mnt path :wink:


1 Like

Good to hear :+1:

1 Like

I had similar problem, someone may find this useful.

My network workgroup is named “HOME” (not the default “WORKGROUP”). I have a Synology NAS named “diskstation”. After I replaced my old router, all SMB requests were terribly slow (like 10 secs to switch folder, 10 secs to start a movie, etc.) The solution was to change the NAS name to include the workgroup name (like domain suffix: “diskstation.home”) custom domain of NAS to match the homegroup name. The name resolution is still not working, but I can play movies from the NAS again.

(2nd edit:)
I managed to get the name resolution working by setting the “domain” name on my router to “home.local”. Sic.