New Vero 4K+ won't boot

Hi all

Just received my 4k+, unboxed and plugged it in but it won’t boot. Lots of failure messages on screen but never boots into Kodi.


See Reinstalling OSMC - Vero 4K - OSMC. This should fix the issue.

Did you unplug the device during initial setup?


No, I plugged it in in the order described in the instructions and this is the result.

Not trying to be pedantic but not a great experience for an “out the box” experience. I have neither an SD card or a USB stick to re-install with. I will try borrow one from someone.

I can appreciate it’s not an ideal out of the box experience.
Reinstalling should resolve the issue, but you can send it back to us if you would prefer.

Thanks Sam. I gave it a good go. I found a USB stick and did the necessary but it simply will not boot from the stick. I tried the recovery method as well and it just will not boot.

So unfortunately for me this is now out of my comfort zone so I would like to return it for a refund. How do I start that process?

You can email

Can you show me a screenshot of the USB stick so I can check that you imaged it correctly? My guess is that you probably just dragged the file over, instead of using the installer to partition the USB stick.

It also needs to be a cold boot rather than reboot.



I used the windows installer:

You can use the toothpick method and it will work, but even that isn’t necessary for a standard reinstallation.


This is what I am saying, I tried it the normal way and recovery, both do nothing. No doubt it is something I am doing but unfortunately I can’t change that lol.

Thank you for your help, I do appreciate it.

Give me a couple of minutes and I’ll send you some instructions which should sort this all out.

Never mind – you’ve requested a refund. Sorry that the product didn’t meet your expectations

FWIW, that hidden “System Volume Information” tells me that it’s likely a NTFS-formatted drive, I don’t believe Vero supports NTFS volume for recovery purposes.

Windows puts them on Fat32 and exFAT drives as well. Most people don’t have ‘show system files’ enabled so normally that folder is not visible to even notice.

I had this same issue… reinstalled via USB and everything worked fine after.

Tried to do it via SD card slot first and that slot is shocking… it doesn’t actually go in properly. it’s like it just rests in the hole lol.

Anyways yeah, reinstall via USB.

You likely put the SD card in the wrong way around. It needs to be put in with pins facing up.

1 Like

Ha… yup! That’ll be it