New Vero 4k+ - won't start/boot

Hi guys,

I just received the new Vero 4k+, plugged it in and it booted up on my screen, so I ssh to the device and did update (dist update). After that after restart Vero doesn’t boot up anymore.

I tried reinstalling with SD card (also renamed to recovery.img) but there is no output through HDMI. The front light isn’t flashing, nor indicating that device is up. Only the SPDIF connector has red light going through it.

I tried different HDMI cables, USB powering, Hard reseting (30s) but nothing seems to help to get output to the screen. Nor I cannot see the device on my local network. And also to the touch feeling, device doesn’t seem to be warm.

Any ideas what else should I do?

Thanks in advance


Did you see the interface come up and did you complete the initial setup?




yes, first time I booted it up, I went through settings, got the the kodi interface, enabled ssh and then after update it stopped booting up.


Did you try reinstallation via USB or a micro SD card?

There’s a bug in older bootloaders which prevents the red LED from illuminating at boot up. So the box may be trying to boot but you can’t see that.

If you plug the USB cable in to the Vero and plug it in to a PC or laptop, does it show up as a device? If it does, the bootloader on the device is completely corrupted (we can fix this trivially). If it doesn’t, your device is still probably trying to boot

Also forgot to add: can you show me a screenshot of SD/USB contents.


I just tried USB also, doesn’t seem to help to boot up. Nor it doesn’t flash light on the usb (when reading).

Plugging it into my mac doesn’t add new device to my desktop, and doing diskutil list doesn’t show any new device.

Sorry - wasn’t clear. Do you have a Windows or Linux machine where you can check lsusb or device manager to see if it appears?

I’ve now sent you a recovery image which you can extract and use with the toothpick method.


here are my USB device, I do not see Vero there:

I tried to boot up your image, but nothing happens (no image on the screen), same as the latest version, that I got from your page.

Okay. I think something is wrong.
Can you please email with a link to this thread and your order # and I will take care of this promptly.

Alright, I have written the email, thank you for your help!

Thanks. I’ll pick it up shortly.