New Vero Box has no power

Just got a brand new Vero4k box. After I plugged in the power there are no lights on the box and no output on HDMI. I tried in different power plugs and also with a different power adapter. Nothing, the box is like dead. What should I do next?

Every device is tested before dispatch, so I’d be surprised if it’s an issue with the device itself.

Can you show a photo of the other PSU you are trying to use?

I have an old switch with the same connector but the adapter has less ampere. With the vero adapter and the original one from the switch, the lights on the switch are lightning but not on the vero box.

I can post a picture but doubt that it will lead to the solution as it looks like the one from vero is working as well.

It would still help to show a picture.

Otherwise, contact with order # and it can be dealt with
Connector doesn’t matter – we need to see the specs of the PSU you are trying with.

Many thanks


Attached is the image. But again, both adapters (the one from the switch and the one from vero) were working with the old switch but not the vero box.

That power supply is only 1 amp. The Vero needs a 2 amp supply.

I tried with the vero one as well and it didn’t work either!!! I’m fully aware that vero needs 2amp. Please read the thread carefully and do not shift away from the main issue that the box is not even booting and is completely dead with the vero adapter. I tested it with another adapter to exclude that the adapter is the issue.

I did read the thread. I did see Sam asked you to try a different supply. I did see that you tried with a 1A supply.

So I’m not sure why you didn’t like my response as I had no way of knowing if you knew that the Vero required a 2A supply.

My only suggestion at this time is to either get a 2A supply, or do as Sam suggested and open a ticket to get a replacement supply.

And why is the old switch working with the vero power adapter? Do you think it is still an issue with the adapter and not the vero box?
Just to be sure what I mean with the term swicth, it is this device Network switch - Wikipedia.

Typically there is no light active in front of the Vero while normal operation. Just to be sure, can you confirm there is no red light for some seconds on the Vero if you connect the box to the original power supply?

What other plugs you tried? Pictures, please.

I can confirm there is no light, I tried different times.

You want some pictures from the power plugs from the walls of my house? Here is one

Sorry, my fault since I’m not a native English. I understood you tried different PSUs but now it’s clear what you meant even to me. :upside_down_face:

As @sam_nazarko suggested here, get in contact with the support. It cannot hurt in referencing this topic and underline that you think it’s not the PSU which is faulty but the box itsself.

I’m also not native English :raising_hand_man:

No – I’d like to see a picture of the other power supply that you have tried to use.
I see you’ve posted that above.

I’ll pick up the ticket shortly.

Many thanks


Yes I opened a ticket at with the order.

Thanks. I will take care of this tomorrow.