New Vero K+ does not boot at all

I received my new Vero K+ today and set it up as per installation guide.

TV = Sony XE9305

Source = USB 3 Stick

The Vero K+ orange light at the front lights up for +/- 5 seconds,.

The screen says “Please stand by” for a short moment, a glimps at the boot menu appears and the screen switches to a pale blue with the Vero logo, athat turns to black.

No wizard or anything else appears, screen just stays black


This suggests that the Vero is indeed starting, but Kodi may not be displaying a picture that your TV can receive.

Do you have another display and HDMI cable you can check with as a test?
Is the connection direct to the TV, or is there an AV receiver inbetween?



I see from your support ticket that you’ve got a USB thumb drive attached. Can you clarify what the intention of this is? The OSMC software is already loaded on the device.



The connection per HDMI cable is direct to the TV, nothing else in between.

I tried my computer monitor, same thing.

From what I can see during the short period it is visible, the boot menu is not at all long, maybe 1/3 of the screen max, if that is of any help.

The change of screen is too quick to read it, unfortunately.

Best regards
Dieter Six

The first thing I would try then is to reinstall OSMC. See Reinstalling OSMC - Vero 4K - OSMC

This should only take 5 minutes and you should see the installation screen come up


I tried the reinstallation as described above, but there is no installation screen appearing.
It starts as mentioned before, then the screen remains black and the USB stick is lit, it has power.
I also tried another stick, same thing.
I can read super block mentioned in the boot menu, too short to make anything out of it

Please show me a screenshot of the contents of your USB stick.

The super block message will just be a filesystem check on boot, and it disappearing quickly indicates the boot is continuing.

You need to run osmc-installer on your PC. But launch it from outside the USB stick.

OK, it finally worked and the device has been set up, thank you.
I will start playing with it tomorrow, it is late and I am tired.
Best regards and thanks again for the help.
Dieter Six

1 Like

Hi Dieter,

I’m glad you were able to get up and running and do apologise for the initial out of box experience.

Is it possible that your device lost power or you unplugged it during the initial boot? This could’ve corrupted the setup and necessitated the need for a reinstall.

We will be here for any questions that you have