New Vero4k+ keeps crashing

Hello everyone. I have had my first Vero4k+ for a couple of years down in the “home theater” or “basement” and it works great. Bought a second one for the upstairs tv and it constantly crashes while playing video files. Not an expert (at anything), but I did notice whilst the log was running high core percentages, with frequently one or more at 100%. Then there is the kodi cpu running from low 30% to 300%. I do not know what that means. Temperature is about 160 degrees Fahrenheit.

So, if anyone can help me out, I would appreciate it. Below is the log.

Thanks, Phil


Looks like the vero4k+ has USB flash drives attached. How are these powered? If they don’t have their own PSU, I suggest attaching them via a powered usb hub.

Thanks Tom.

Can you post a log from the working Vero so we can see if they’re on the same version of OSMC?

Hi Tom. They are plugged into their own psu and then into a powered hub. Same hub type as used on the other setup as well.

Yes I can, Sam.
Of course, it crashed on the menu.

From your ‘bad’ Vero, this shows a playback issue:

2022-04-20 20:05:35.305 T:10916    INFO <CUPnPServer[osmcup]>: Received Browse DirectChildren request for object 'library://video/movies/titles.xml/', with sort criteria 

Did you restore a backup from the other Vero to this new one?

My suggestion is:

  1. Swap power supply, hubs, and any other peripherals with the other Vero. Does the other Vero have any USB drives attached?
  2. Enable debug logging under Settings → Logging.



I’ll try those swaps tonight after work. And yes, both setups have multiple usb hard drives attached.
I setup the Veros independently from one another off the internet through osmc, and did the rest of the variable settings by memory or intuition.
I understand some of the hardware issues with usb hubs and multiple drives. I normally go through the FILES menu to allow time for the drives to all “wake-up” from standby before watching movies.

I’ll post again tonight. Thanks everyone!

1 Like

Keep us posted

This evening I used the older Vero4k+ on the newer powered usb hub with 3 powered usb hard drives. It played from every drive flawlessly with minimal core or cpu usage. To my mind, that eliminates problems coming from this usb hardware. We ended up watching The Taming of the Shrew (1967), which had crashed repeatedly before.

Tomorrow after work I’ll try the new Vero4k+ on the older setup in the home theater.

This is all very interesting to me. Thanks for your patience!

The new Vero4k+ was used in the Home theater, which includes a powered usb hub and 6 powerwed usb hard drives. Was able to play files sucessfully immediately after connecting, but return trips to the menu caused crash.
Here is the log file:

Some of my thoughts and observations:
The menu crashes seem to be caused by database updates and background syncing.
The database for these video files are saved on the Vero, and it is substantial. Should I offload the database to another hard drive?
Should I wait longer for the database processes to finish? We gave it about a week of uptime without watching anything.
There was a time when I could stream video files throughout the house, but Windows and my network updates have repeatedly put an end to that, defeating every work-around. So, if streaming is removed as an option, can I disable some of the UpnP settings?

Thanks for your efforts!


Thanks for your patience. It’s been busy.

Apr 24 10:42:53 osmcup mediacenter[2394]: /usr/bin/mediacenter: line 218:  2631 Killed                  sudo -u osmc MALLOC_MMAP_THRESHOLD_=8192 LIRC_SOCKET_PATH=/var/run/lirc/lircd $KODI --standalone -fs
Apr 24 10:42:53 osmcup mediacenter[2394]: Kodi exited with return code 137 after 38 hours, 45 minutes and 33 seconds
[ 1147.907478] Out of memory: Kill process 2689 (kodi.bin) score 613 or sacrifice child
[ 1147.907794] Killed process 2689 (kodi.bin) total-vm:2838868kB, anon-rss:1247692kB, file-rss:0kB, shmem-rss:0kB
[ 1148.389856] oom_reaper: reaped process 2689 (kodi.bin), now anon-rss:0kB, file-rss:0kB, shmem-rss:0kB

Kodi seems to be running out of memory and as such, the process is killed.

Could you let us know the size of the library in terms of # films, tv shows?
2GB should be more than ample, so I’m sure we can get this solved.



Oh boy. 3 hard drives for 20 terabytes. Approximately 2000 video files, on the new Vero.
Then there are 6 hard drives in the main, about 58 terabytes, god knows how many video files on the old Vero. Please note that the old one runs fine with the exception of one folder where it crashes on one video file I’ve yet to identify.

I have restored the new Vero to its rightful place. Have changed the settings on UPnP to match the old Vero (disabled), and we successfully watched a 1 hour 40 minute movie with no problem.

So might the libraries be choking the stuffing out of Kodi?

There may be a memory leak in Kodi which is causing this crash. I’ve seen this for other users with very large libraries and I am still trying to track the problem. The good (and bad) news is that it affects Kodi on other platforms, like PC, so it’s likely to get fixed.

The bad news is that as PCs usually have more memory, it takes a longer time to run in to the issue.

Is your library fully scraped yet? If not you have a couple of options. 1. You can leave the device until it’s all scraped. If Kodi crashes, it will restart and resume scraping. Eventually this will complete. 2. Alternatively, you could use Kodi on Windows or Mac to do the initial scraping. This will probably be a bit faster. Then you can either export the library or use a shared library. The shared library option makes sense if you plan to use multiple devices in the house.


1 Like

That sounds like the best way to go, Sam. I’ll read up on shared Library. Thanks, all of you, for the help!

Let me know how you get on. The shared library uses MySQL. This may be a bit tricked to configure on PC but on OSMC, details can be entered under the My OSMC menu


Will do. I may wait for a long weekend to invest the time, but I’ll put it here once I do. Disabling UPnP has it running for now though. Shall we call this one solved?


If you were planning on switching over to a mysql setup you don’t really need to do it all in one go. You can setup the MariaDB on whatever device you want and then just use Kodi on a PC to setup your library, sources, watched status, etc. Once your happy with that then you can just copy the advancedsettings.xml and sources.xml files from the PC to the clients and restart Kodi and it will be switched over to the new database. You may want to delete the thumbnail folder and texturecache13.db on the clients at the same time to free up some space.

Wow Darwindesign! Those instructions will be a big help when I start. Thank you so much!


1 Like