New Vero4k won't recognize Keyboards (Rii or Apple USB)

I’m setting up the new Vero that will shift the longsuffering Raspberry3 downstairs. on the rPi I use the Rii mini keyboard, and it’s a champ. While the Vero keyboard is nice, it’s hard to type on it (inputting a fixed IP address was nigh impossible!). HOWEVER, the Vero doesn’t recognize the Rii keyboard. I’ve tried it using both the Vero and Rii dongles side by side, or each alone, but there are no keystrokes recognized. I’ve also tried an old apple USB keyboard, and it’s not recognized either. I looked at the log and at least the Apple keyboard is logged. Plugging the Rii dongle back into the RPi, and it works as expected on the RPi.

An old post had an issue with the apple keyboard with a mouse plugged in, and the guess there was that it has to do with USB power; running the Rii alone shouldn’t need much power.

Here’s the log http://paste.osmc.io/oyamaqojeh

Grateful for suggestions; I was going to get another Rii, but maybe not…

Dennis

Can not see the Rii anywhere being detected.
Can you install usbutils sudo apt-get install usbutils and provide output of lsusb. And please do that when Rii connected to Vero4k and Pi3.

I installed the USB utils (I had not done that) and rebooted. The Rii is not recognized. Here is lsusb (with the Rii dongle plugged in)

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 002: ID 2252:1037
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

(the Edimax is the Rii dongle, it disappears from the list when unplugged. )

I’m trying this in the OSMC app; I started to reboot into terminal, but I don’t know how to do that without a keyboard.

Thanks,
Dennis

Not sure what you mean with this. But I recommend you access the Vero4k via SSH to do this testing.

That would be quite strange as this is a WIFI dongle http://www.edimax.com/edimax/merchandise/merchandise_detail/data/edimax/global/wireless_adapters_n150/ew-7811un/ could it be that you took the wrong USB adapter from the Pi and that the Rii keyboard one still in there?
Which exact Rii keyboard do you have?

1 Like

Thank you for the very gentle correction, fzinken

Yes, the wrong dongle was in my usb extender (that leads to a point above the TV. When I reassembled my RPi after moving, I had switched this and hadn’t noticed.

With the correct dongle (cleverly labeled “Rii”) installed in the Vero, the Rii works great. I appreciate your working this back to first principles, which I had not apparently been able to do.

Solved, or actually not a hardware problem in the first case.

Thanks

Dennis

1 Like

We appreciate your honesty, we all make mistakes.