New WiFi adapter not connecting at g?

Up until now, I have been running my Pi wired through a modified LinkSys router running OpenWrt configured as a bridge, which was only capable of 802.11b wireless mode. I just got an 802.11b/g/n wireless dongle to review, so I plugged it in to the Pi and got that working with little to no problem. The thing is, from what I’ve read, I don’t think it is connecting in ‘n’ mode. When I run iwconfig, it reports the bit rate as 54 Mb/s. Now that is far better than the 11 Mb/s it must have been getting through the LinkSys in ‘b’ mode, but should that not be higher if it were in fact connected in ‘n’ mode? From this link - http://ubuntuforums.org/showthread.php?t=1483768 - it looks like it should read 300 Mb/s, but since my router, a Belkin N150, claims “…allowing for data transfer speeds of up to 150Mbps across your network…” I would think that the bit rate should be at least that? No? This is my only other “n” device, so I don’t have anything to which I can compare it.

Thoughts? Thanks.

Install wavemon and check what the link quality is and which speed is reported there.
And on 20 MHZ don’t expect more than 130M

Link quality is 99-100% and the bit rate being reported there, while a video is playing, is 54 Mb/s. I have the router set for 20/40Mhz bandwidth, or did you mean the dongle?

Well it seems you only have 20MHz with single stream

Hmmm… this is the WiFi setup on my router… so is this because the dongle isn’t connecting at the rate it advertises, or because the router isn’t operating correctly? Sorry if these seem obvious. Most everything I owe is still “b” mode!

I just noticed something. On the “spec” sheet that came with the dongle, it says:

Working Channel Number: 13

That means that this only works on channel 13? The router only goes up to channel 11. I changed that to auto and the “extension channel” on the router changed to 4. The channel field on wavemon followed that to 4 as well.

I think this will slow everything to b speeds if there is a b device connected. Try temporarily changing wireless mode to g and n only and see what happens.

Check the security settings on your router to ensure that wpa2 aes is enabled and wpa tkip is disabled.

According to the wifi spec N wireless modes are not available with wpa tkip so if the client connects using this security mode it will be limited to 54Mbps.

1 Like

I told you I was old-school! lol… I was still using WEP encryption. I live in the country and the only ones who are going to be hacking my network are the cows, so… :slight_smile:

I did change that to WPA and sure enough it did bump the bit rate up to 72.2 MB/s, so at least now I know that it is connecting in ‘n’ mode.

Once again, I appreciate all of y’alls help!