Newbie setup issues

Hi all,

I’m an OSMC newbie with a very shallow knowledge of Linux. I just got an RPi3 with noobs pre-installed (I bought a Canakit) and I’m working on getting the Pi set up to run OSMC. I’ve had a couple problems, and I’d appreciate any help I could get. Thanks in advance.

As background, I have NextPVR running on a Windows 10 computer as my “back end”. I have Kodi running on a Windows 7 laptop with the NextPVR client enabled and properly configured. I can see and play my recorded TV programs and videos that are stored on the Windows 10 PC from the Windows 7 laptop. I have “shared” certain directories on the Windows 10 computer and was able to browse to their locations on the Windows 7 PC when adding videos to it.

My objective with the Pi is to replace the laptop with it, thereby reclaiming my laptop for other uses.

Today I began trying to set up the Pi with this in mind. I booted the Pi up into noobs and connected to my wifi. I was presented with several operating system options, as expected. One of them was OSMC Pi2. That seemed like a problem to me since I’m running a Pi3, so I looked around for what to do. The best I could find was to create a bootable SD card from scratch and boot from it. I don’t have a spare SD card, and if I have to do that, I’ll get one and do it. In the meantime, I went ahead and chose OSMC Pi2. The result was an apparently successful installation of OSMC, but I’m wondering if I should have a different version installed, specific to the Pi3.

I enabled the NextPVR addon inside OSMC and configured it to access the backend by entering appropriate configuration information. As a result, I can watch live and previously-recorded TV, I can see all the channel logos and channel guide, almost exactly like they appear on the Windows 7 PC. Live TV is a bit choppy at times, and I understand I need to install the two codecs available from the Raspberry Pi Foundation. I found the serial number on my Pi and I’ll soon order the codecs.

Now I’m trying to access other (not recorded TV) videos I have stored on the Windows 10 computer. I go to “Add Videos” and try to browse to their location, but I can’t. The Windows 10 shares don’t appear as they did on the Windows 7 laptop. I also try to navigate directly to the directories containing the videos by entering either smb:\192.168.1.66\Recorded TV or smb:\LACROSSE\Recorded TV as I had done on the Windows 7 laptop (LaCrosse is the name of my Windows 10 computer, and 192.168.1.66 is it’s IP address on my network.) No joy. OSMC seems to accept the path and asks me to give the source a name. I do that, but it just keeps asking me for a name after I’ve entered one. I have read here that there is a problem with samba and I have to use a different approach to access the shares, but I can’t figure out what to do; it’s probably due to my lack of Linux skills. Or perhaps I simply need to install samba from the app store? I have not done that.

Can anyone help me access my shared videos? Do I have the wrong version of OSMC installed on my Pi3?

Thanks again.

Hi,

I would recommended using fstab mounted shares, rather than the kodi shares; as you will no longer have these browsing issues and should get better throughput.

Thanks Tom.

Thank you, Tom. I’ll try your suggestion, but just a couple more questions, please.

As I said, my knowledge of Linux is shallow. I don’t use a username or password to access my shared folders. I’ve shared them with “everyone” via Windows 10. Is there something I need to do in Windows to set this up? Can I omit the username and password in your tutorial?

I have not set a root password on the Pi. Is sudo going to ask for one?

Thank you again.

Hi,

I believe you add the entry without a username and password @bmillham could you please advise?

On osmc sudo is passwordless, so no you will not be prompted for a password.

Thanks Tom.

While standing by about the username and password question, perhaps I should mention a couple other points.

First, I went ahead and enabled the smb addon from the app store. I then proceeded to try to add the directory containing my videos. I got to the point where I selected “browse” and saw the “Windows (SMB)” option available. I selected that and after a couple seconds, OSMC returned nothing. Evidently it found no SMB shares, even though I know the files are there and I’ve shared them with another Windows device.

Also, while we’re at it, can someone confirm that I haven’t goofed up by selecting the Pi2 (instead of Pi3) option while in noobs?

Thanks very much for the help.

Instead of supplying username=xxx,password=xxx you can just give the guest option.

1 Like

Pi2 and Pi3 use the same image, so no worries there.

Samba install from the store is to share your pi3s files to a windows computer. Say you got an usb disc connected to the pi3 with alot of media on it and you wanted to view it from your windows machine or add to it, then samba from the store makes it posible.

Whenit comes to pi3 as smb-client I’d go for the fstab option.

Hi,

As Joakim_Sandstrom has stated the samba app in the osmc store, is for sharing files from the pi; not for accessing shares on other network devices.

As for adding shares via browse, Windows SMB; doesn’t working unless you change the smb protocol to smbv1 (but this ins’t considered very secure) You can find this option under settings, services smb client. Alternatively you can specify the path manually, you should be ok just to copy the path used by kodi on the windows 7 pc.

As for fstab just to clarify bmillham’s post, the example from his guide using guest instead looks like this:

//192.168.1.2/Movies /mnt/Server_Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,guest,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

Thanks Tom.

Thank you bmillham, joakim, and Tom. I think I can make some headway now !

1 Like

Let us know if this works. I’ll update the guide to include the guest option.

I don’t think Win10 allows anonymous (guest) ie passwordless access without a registry hack. ‘Everyone’ means anybody with a login on the server, so you will have to use your own login or create a new user just to access the shares.

YMMV

I don’t think Win10 allows anonymous (guest) ie passwordless access without a registry hack. ‘Everyone’ means anybody with a login on the server, so you will have to use your own login or create a new user just to access the shares.

I’m not exactly sure what this means, but right now I’m accessing my shared files on the Windows 10 machine from my Windows 7 laptop. My laptop has a username but no password. Maybe this is just one of those “Windows” things; i.e., you need a “proper” login to get files to Linux but not to another Windows machine.

I will try the “guest” approach. If that doesn’t work, I’ll create a username and password on the Windows 10 computer for use by Pi3 running OSMC. Then I’ll report back my results.

Thanks again for everyone’s help.

I couldn’t make either approach work. I think I’m having some syntax issues with Linux. But, for what it’s worth, there is currently only one line in the /etc/fstab file. So the line I added was line 2. I copied exactly the guest line Tom provided above, then typed:

sudo mount -a

I got the following response:

mount: /etc/fstab: parse error at line 2 – ignored
mount: mount point 0 does not exist

Then I added an account for kodi’s use to my Windows 10 machine and entered those details into line 2 in /etc/fstab (there are now 3 lines, with the second one continuing using the “” character)/

I then typed, as before sudo mount -a, and got exactly the same response.

For reference, this is exactly what I put in lines 2 and 3 of my /etc/fstab file (my shared folder name has spaces):

//192.168.1.66/Other\040TV\040Shows /mnt/LaCrosse_Other\040TV\040Shows cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=kodi\040with\040space,password=2013LaCrosse_kodi\040with\040space,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

Obviously something is wrong with the way I’m creating the mount point, but my very shallow knowledge of Linux prevents me from figuring out what to do.

Again, any help is appreciated. Apologies for my lack of Linux knowledge.

Thanks!

This indicates a problem with your fstab file. Exactly how are you editing the file? And is your username really kodi with space? That’s how it looks to be from what you copied.

Tell us this, what is the share you are mounting? It is “Other TV Shows” and you want it mounted as “LaCrosse TV Shows”?

What is the username and password, I find it hard to believe they are what you have in the fstab. (Don’t share the password, just confirm if it has spaces in it)

Thank you bmillham.

My username is kodi. The password is abc123_kodi (not the real password, but it has numbers, letters, and an underscore in it. (The “with space” stuff appeared in the document I was reading and I thought I needed to copy it exactly. Clearly that was wrong.)

The share I’m trying to mount is Other TV Shows. It’s a folder on the Windows 10 machine located at G:\Other TV Shows. I want to call it LaCrosse_Other TV Shows on OSMC. LaCrosse is the name I gave to the Windows 10 machine.

Again, thanks very much or your quick and helpful responses.

This is what your fstab line should look like:

//192.168.1.66/Other\040TV\040Shows /mnt/LaCrosse_Other\040TV\040Shows cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=kodi,password=abc_123_kodi,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

Well, my fstab line now looks (almost) exactly like yours, and I end up with the same response when I issue the sudo mount -a command.

mount: /etc/fstab: parse error at line 2 – ignored
mount: mount point 0 does not exist

The only difference between what I put into fstab and what you have is that I split the new line at rw, so my lines 2 and 3 look like this:

//192.168.1.66… noauto,rw,
iocharset=utf8,…,dir_mode=0770 0 0

Thanks again for your help.

You can’t split the line! It must be one line.

Aha! Thank you! But I’m afraid I’m not there yet.

I made the correction and then proceeded as follows:

sudo mount -a
sudo systemctl daemon-reload
sudo systemctl restart remote-fs.target

and finally,

cd /mnt/LaCrosse_Other\ TV\ Shows,

at which point I get this:

bash: cd: /mnt/LaCrosse_Other TV Shows: No such file or directory

Close, but no cigar!

Thanks again for your help!

Ok, just why are you trying the systemctl stuff??? No where in my tutorial did I tell you to do that.

That happens if you try to:

ls -l /mnt
sudo mount /mnt/LaCrosse_Other\ TV\ Shows