Newbie setup issues

The systemctl stuff came from here

I do appreciate your help and persistence. Thank you very much for that. I am not very Linux literate. For that I apologize again.

What should I do now?

Do what I asked you to do???

I did not recognize your last post as a request for me to do something. I apologize.

So, I typed
ls -l /mnt

And got this response:
total 0
drwxr-xr-x 2 root root 0 Feb 15 21:45 LaCrosse_Other \TV Shows

Then I typed
sudo mount /mnt/LaCrosse_Other\ TV\ Shows, as per your directions

And got this response:
mount: can’t find /mnt/LaCrosse_Other TV Shows in /etc/fstab

With growing frustration, I noticed that the name coming out of ls -l /mnt command was LaCrosse_Other\ TV Shows, not LaCrosse_Other\ TV\ Shows, so I decided to issue this command:

sudo mount /mnt/LaCrosse_Other \TV Shows

The above produced more than a screen full of output, suggesting to me that the directory had been mounted. I didn’t see any errors.

My next step is to check if Kodi can see the share. That can wait until tomorrow.

Again, I appreciate your help and patience. Have a good night.

As you seem to be having problems with spaces, I’d suggest that you don’t use spaces in the mount point. Try something like this:

sudo mkdir /mnt/LaCrose_Other_TV_Shows
sudo chmod 777 /mnt/LaCrose_Other_TV_Shows

And change fstab to match:

//\040TV\040Shows /mnt/LaCrosse_Other_TV_Shows cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=kodi,password=abc_123_kodi,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

Hi all,

I’ve had to wait until the system allows me to post another message because I’m a new member. So, please pardon me for the long delay in my response.


Thank you for your assistance and persistence throughout my experience so far. Despite my best efforts, I was unable to make the “fstab method” work. This morning when I tried to “Add videos” through OSMC, I was able to navigate to the /mnt directory in OSMC and I found my LaCrosse_Other TV Shows directory, but there was nothing in it. I apologize for my lack of ability. I sense growing frustration in your responses to me, and, frankly, I don’t blame you for that.

I’m giving up on the fstab method. I changed the SMB protocol to smbv1 as noted by Tom above and was able to browse immediately to my videos and make them available to OSMC. I have no idea what security fears I should have or what performance issues I should expect, but at least this method works for me.

A couple points for your consideration, and perhaps to help others trying to configure a Pi with OSMC: First, I’ve proven to myself that the fstab method is a real stretch for anyone with limited Linux command line skills.

Second, probably related to the first, I think the “spaces” problem is a real limitation of the fstab method, especially for anyone who has previously defined share names with spaces in them. Some of us, myself included, have multiple devices on our networks that use names with spaces just fine. Changing the share names to remove spaces requires changes to all the network devices using the shares. On the other hand, the way to deal with spaces on the Linux command line varies with the command you’re issuing. It was really easy for me to make mistakes. I think you may have made a mistake yourself in one of your recommendations to me.

Also, you were critical of my use of “systemctl stuff” (see above). I pointed out why I was doing that by referring to a previous post I was referred to here, but you may not have noticed who wrote that post. (Hint: You did.) So, if the “systemctl stuff” I did is wrong or should not be done, maybe you could clarify your documentation? That might help others.

So, I’m moving on to other setup issues. I’ll start new threads if I need help with any of these. For anyone following along, here’s where I am:

I’ve installed codec licenses correctly (verified on the command line).

I have some buffering watching Live TV, especially on one TV channel. I need to look into how to fix that because that channel is unwatchable now

I need to figure out how to configure Wake On Lan settings. I want OSMC/Pi3 to wake my Windows 10 PC but it’s not doing that right now

I have a Flirc USB dongle I’m going to use with my remote. I’ve got it configured with the Windows 7 laptop and it works well. I’m expecting to plug it into the Pi’s USB port and have it work without any further issues (fingers crossed)

Again, my thanks to everyone who helped me get set up.

Opps, I totally forgot that I had put that in there. My bad. I questioned it because it wasn’t needed for what we were trying to do.

That’s not true, allot of people use fstab that are new to linux.

Yes, it’s a bit of a pain that you have to use \040 in fstab and \ on the command line. But since editing fstab is normally only done on initial setup, and later if you need to add a new share it’s not really that bad. You could do like my last post suggested and just use _ instead of for the mount. Of course, the mount doesn’t have to match at all what the share name is. You could just mount the share as OtherTV.

I think that improvements are planned for MyOSMC to allow editing fstab directly in the Kodi GUI. This would definitely make things easier.

I’d still recommend that you get fstab working. It will be better in the long run.

And sorry if you think I was getting frustrated with you. It was more frustration that we were having so much trouble.

This sounds like a great idea. I look forward to seeing these. Off topic, I think my buffering issues are due to heavy congestion on the 2.4G wifi band around my house, so I’ve purchased a 5G adapter from the OSMC store and will need to disable the onboard 2.4G adapter to use it. I’ve seen many posts on that topic here and have been fearing another miserable encounter with the command line.
Then I noticed that the My OSMC interface allows users to add lines to config.txt in a simple way. Something like that for fstab would be nice.

I take your recommendation onboard. I’ll work on it when I get everything else going the way I want it. I’ve left the line in the /etc/fstab file and it hasn’t affected anything. I must have some kind of syntax problem that I’ll have to find. As I said, the directory is accessible via OSMC, but there’s nothing in it.

No worries. Thanks again for your help.

hey you guys!
I have printed a copy of this post and added it to my PiOSMC HANDBOOK because it is as close to a user manual as I have seen, w/r to OSMC installation and tv/samba setup. You have answered far more questions than were asked: neat. Really neat.

Have a look at This should be your first port of call for Kodi related questions.

I’ve been doing some more work configuring my Pi/OSMC and thought I’d post my status in case it might be helpful to others.

Buffering with Live TV. I’m pretty sure this is being caused by congestion in the 2.4G wifi band around my house. I have powerline ethernet adapters and I used one of them to connect my Pi in a room where the powerline adapter delivers decent bandwidth. When I did, the buffering disappeared.

I’d be happy to use a powerline adapter for the Pi when I put it in my living room with my TV, but I can’t get sufficient bandwidth from any of my electrical outlets near my TV. Running ethernet from my router to my TV location would involve some tricky work in my attic, so I’m not going to try it for now. I think the solution is to connect with wifi at 5G, so I’ve ordered an adapter from the OSMC store and I’m waiting on it to arrive.

Flirc dongle for remote control. As noted above, I had this configured to issue Kodi keyboard commands mapped to remote keys. I had success using this with the Windows 7 laptop, and all I had to do is plug the Flirc dongle into the Pi to make it work there. My remote works perfectly with the Pi/OSMC

fstab shares. Success! I went through the syntax of line I added to /etc/fstab and decided it looked correct, but I decided to simplify my life a little and use names on the Pi that didn’t have spaces. I also made sure my backend was awake. It might have been asleep last week when I was trying to do this. Anyway, the shares on my backend are now mounted on the Pi and accessible to Kodi. The only question I have left is what happens when the backend goes to sleep?

Wake on LAN. I’m struggling here. I did post a question elsewhere on this forum and was referred to the Kodi forums. I did that and I’m awaiting a reply but, as each day passes, I’m thinking the chances of getting anything from there are minimal. I’m wondering how folks configure OSMC/Pi so that it works well with a backend that goes to sleep. I’d like to get a solution that’s “wife friendly”. Any suggestions would be appreciated.

Thanks again for all the help.

Glad to hear it! I know that space handling can be difficult :wink:

Is the ‘backend’ a NAS? Does it really go to sleep, or are the drives just spinning down. If the drives are spinning down then that should be fine. There will just be a delay when access content if they are sleeping. If it’s the NAS going to sleep, that’s a different story. Easiest solution may be to allow the NAS to spin down the drives, but stay awake. That’s how my setup works, and I have no problems.

No, the backend is a Windows 10 desktop. My shares and NextPVR are running on it.

I should have remembered that…

So the WIn10 system is really going to sleep then? I’ve never tried this, so maybe someone else can help with that. It would take WOL, but again, that’s something I’ve never used.

Until you can get an answer on the Kodi forums (or if someone here has any ideas), you may consider just keeping the Win10 system awake for the WAF.