Newbie with Vero....in fact I don't even have it yet!

Yes, those to steps and you should have a working system with 3D

@KaraokeAmerica

… that is also likely to be broken, fixed, broken, fixed, several more times before a stable 3D build is finalized. You must be aware that what you are installing here is experimental development software. Any requests for support for broken features/functions in these builds may not be as highly prioritized by the dev team as you might consider them for yourself.

1 Like

…and once you switched your system over, for the time being, you will want to not update again until you see something posted in the testing thread that says otherwise.

1 Like

So I got my Vero4K+ today! Yay!

Out of the box it is running “OSMC November 2019 2019.11-1”

Will this support 4K and 3D-MKV or is it too old…or too new? I was going to try it as is to see what happens as long as there are no security issues. I don’t have any external ports forwarded to the Vero4K so hopefully I’m good.

You can try if 3D works but I doubt it.
As written above for proper 3D you would need to install the 4.9 Kernel.

As installing the 4.9 kernel will update your complete system to the latest versions you then also need to downgrade the Mediacenter via
sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13

All these steps would be done on the command line see
https://osmc.tv/wiki/general/accessing-the-command-line/

OK, thanks for all the help here. I followed the instructions several posts back:

When I log in via SSH now it says:

> Linux Vero4K-1 4.9.113-20-osmc

However, in “My OSMC” it still says:

OSMC June 2020 2020.06-1

Even though when when I ran the commands it said it was downgrading my version. Should it be this version or did I miss something?

Thanks again for everyone’s help!

You can verify the version of Kodi running by checking Settings > System info > Summary

The lower right corner of the screen will show what version of Kodi is running.

The OSMC version remains on June 2020. You just downgrade the mediacenter.
What is the output of dpkg -l | grep mediacenter

ii  mediacenter-addon-osmc                3.0.688                           all          OSMC addon for mediacenter
ii  mediacenter-eventclients-common-osmc  1.0.2                             all          Eventclient common resources for mediacenter
ii  mediacenter-send-osmc                 1.0.0-4                           all          Eventclient send for mediacenter
ii  mediacenter-skin-osmc                 18.4.0-30                         all          OSMC skin for mediacenter
ii  vero3-mediacenter-osmc                18.6.0-13                         armhf        Media Center package for OSMC

Before my last post I ran this and saw it was 18.6:

grep Kodi .kodi/temp/kodi.log | head -3

Honestly, I’m such a newbie I really don’t know exactly what versions go where.

I can’t wait to play though!!! I can confirm the Plex plugin works in at least 2D. Don’t know yet about 3D.

Looks all good, you should be fine to go.
While I am not sure if 3D detection works through the Plex plugin.

Well, I’m fixin to find out…hopefully in a few minutes!

So…first trial: not successful.

Up front I realize I went backwards on versions to an older one and can expect issues. I’m only describing them here for the purpose of information to developers. If it’s redundant I apologize. All of these trials are using the Plex add-on as well, which didn’t seem to cause me any issues on the Pi3 so I am using that as a baseline.

I’ll try to get a video clip of this, but on two different TV’s the Vero, even the Vero interface itself is “blurry” and clears up a few seconds after all movement stops. I mean even the menu items. It’s not the TV and I tried to change some settings in the video like the refresh rate from 60 to 59.96 and back. Didn’t help anything.

4K will play even in Plex add-on (connected to GB Ethernet anyway) but it is exceedingly slow to load/play. I don’t get HDR to register on the TV, but don’t know if that is the Vero or something else in the video chain like AVR etc. I don’t play a lot of 4K so I’ll have to play with that more. Most of mine are UHD rips to HEVC-MKV.

3D TAB/SBS will play as of course it’s only 1080, but does not register on the TV like OSMC on a Pi3 does though the same connection. That will switch the TV into 3D mode through Plex plugin. The Vero does not.

3D-MVC doesn’t play at all…at least through Plex add-on. if I start to play a movie the Kodi 3D mode box pops up and asks what mode I want, then once I select an option (original) and click OK the screen goes black. Period. I thought maybe it is just slow to load, but I waited a few minutes and nothing ever happens. Hitting the down arrow doesn’t even bring up the movie menu with controls at the bottom. It’s like the Vero can’t speak the same language as the TV at that point. If I hit the back arrow a few times I can get it to leave that movie and see the popup saying that it left 3D mode, but can never get past that. I tried several titles, all which play fine on the Pi3 in OSMC and LibreELEC.

If there is anything anyone wants me to try in this configuration I will if it helps gather data. Otherwise I’m going to re-upgrade it to the latest build (I’m guessing I can do that the same way I installed this one:

sudo apt-get install --reinstall vero3-mediacenter-osmc=APPROPRIATE-VERSION

…without having to re-add or change any respositories?

Overall, I like the aesthetic and I think it’s a cool box! Thanks @sam_nazarko for developing this. I look forward to more playing!!

(PS: I love Discourse and want to use it on my sites, but trying to figure out how to get it to run on a commercial host or even an RPi. LOL)

For trouble shooting provide logs via grab-logs -A and share the URL.

For upgrade just run sudo apt-get dist-upgrade

1 Like

It sounds like you may need to go into the settings in the Plex add-on and enable directplay as well as make sure it is setup to work on your Plex Server as well. If you are not familiar with what this is you should be able to find a guide on the interwebs fairly easy on how to configure. Basically Plex by default may route your stream over the internet and/or transcode things it does not need to. If the Server and client are on the same LAN and directplay is working then Plex works the same as it normally, except when it plays a file it opens the original untouched file in Kodi over a regular SMB or NFS connection the same as it would if you were not using Plex. This allows for you to use Plex for library management and sharing without suffering any limits like subtitles forcing transcode and limited audio format support (I don’t think high resolution audio formats work with this add-on without directplay working).

https://paste.osmc.tv/voqulodovu

Interestingly, I noticed that if I let it sit and spin with the black screen for a few minutes, it doesn’t ever appear on the screen, but in my “Continue Watching” list in Plex it does put it there with progress showing. It’s playing or at least the system THINKS it’s playing.

GUI Resolution: 1920x1080 @ 60i

You should switch over to progressive output

Adjust display refresh rate: Off

and this to “on start/stop” (this is in player settings)

Plex is trying to transcode something it can’t keep up with?

Those settings were already set to enable direct play/stream. I can confirm it isn’t transcoding by looking at my Plex dashboard. I played a 4K/Atmos track and it showed direct play for both audio and video. Of course before this I had to enable pass-through as well as all the formats that my AVR can handle, which is all of the ones listed.

I now upgraded to the current “stable” release. I did play around with a few different titles to see what would happen.

I played a 4K-Atmos title and it played fine. I have the same title in 1080 with Atmos and that played fine and the colors were way better. I’m guessing it’s because I’m doing the current testing on my 1080/3D projector which can’t play HDR at all.

I can play 3D-MVC fine as far as playback goes. It pops up the Kodi 3D mode box , I click on “same as movie” and it plays fine. It is of course not in 3D. If I go into my projector settings to manually put it in 3D, it doesn’t even detect a frame packed stream. I only have SBS/TAB options. Again, not unexpected.

One time it did crash when transitioning between titles:

https://paste.osmc.tv/oxaraguquj

Other than that I rebooted it and it’s playing currently. All my audio types seem to work, I can play 4K although if I try to FF any significant amount of time it just seems to hang with 4K titles. 1080 seems to work fine so far.

Adjust display refresh rate: Off

You still would need to change this setting to get proper playback

Settings>Player>Videos>Adjust display refresh rate> On start/stop

Can you tell me what specific thing this combats? Is that related to the crash I had or for something else? With the current build everything but 3D seems to work.

No, not related to the crash but only with that activated the Vero will switch Resolution and Framerate to match your videos.

1 Like