Newest 2015-07-01 / 2015-08-03 OSMC Release Install Successful but Won't Boot - Constantly Cycles (not reboots) to Sad Computer Blue Screen

Hello all,

First my Hardware is:
Raspberry Pi 2 B+ / 1GB Ram, Quad Core
SD Card (8GB Extreme, worked fine with 2015-06-01 version)
Direct Ethernet Connection
HDMI output connected
2.1 Amp Power Supply and Proper Higher Current Mini USB Cable ( I had the odd rainbow cube when I first installed and figured out it was how the Pi2 indicates inadequate supply voltage).

To begin as stated above my entire build / setup worked quite fine with 2015-06-01 version install and has been for weeks, using 2 different SD Cards (one SanDisk 8GB Class 6 and one SanDisk Extreme Class 10, 8GB, yes the Extreme was marginally faster).

First I saw there was a new upgrade notification for OSMC this evening (about 5:00 PM EDT), I checked the release notes and figured why not since finally osmc has Kodi 15… wow was I disappointed, the osmc upgrade seemed to work perfectly, osmc said it installed successfully and yet after reboot I see the pretty osmc splash screen followed by the “Sad Computer Blue Screen” which just keeps cycling between Black Screen and “Sad Computer Blue Screen”

Thinking this may somehow be a glitch in osmc update process, I manually downloaded: OSMC_TGT_rbp2_20150803.img.gz and after a partition wipe and reformat to FAT32/Primary (same as always) and using the windows SD Card installer, I tried again…

Again the install succeeded, first reboot took a while (database migration?) and finally pretty splash screen followed by constant “Sad Computer Blue Screen” cycling over and over.

I pulled the SD Card(s) (yeah I’ve tried GPT and MBR and multiple methods of formatting) and checked install.log which shows NO ERRORs and a Successful Install… Rebooting.

So if anyone has any suggestions (besides go back to 2015-06-01) for the Pi2 or a similar experience please share?

I did search these forums first for anyone having my issue and could not find any relevant information, other glitches and minor bugs here and there but nobody with the Sad Computer screen over and over again.

Thanks in advance!


Known issue. We’re building new images. For now use June image and update. There should not be an issue upgrading from the June release. If you do have an issue, please post a log.



So to be clear it is a known issue with the img.gz from images page and your rebuilding but in the meantime to get a proper update:

1.) Install 2015-06-01 First (June Image) and let osmc completely install
2.) Let osmc perform it’s own update again

I presume this means that the update will pull a proper image or with it pull the proper upgrade files individually to properly update?

Thank you for the quick response and verification of solution :smile:


Just in case, my install logs from clean image install… I will perform install as you suggested now.

Thu Jan 1 00:00:09 1970 Starting OSMC installer
Thu Jan 1 00:00:17 1970 Detecting device we are running on
Thu Jan 1 00:00:17 1970 Mounting boot filesystem
Thu Jan 1 00:00:17 1970 Trying to mount to MNT_BOOT (/mnt/boot
Thu Jan 1 00:00:17 1970 Using device.boot: /dev/mmcblk0p1 and FS: vfat
Thu Jan 1 00:00:17 1970 Preseed file found, will attempt to parse
Thu Jan 1 00:00:17 1970 Found a definition for storage: sd
Thu Jan 1 00:00:17 1970 Creating root partition
Thu Jan 1 00:00:17 1970 From a root partition of /dev/mmcblk0p2, I have deduced a base device of /dev/mmcblk0
Thu Jan 1 00:00:17 1970 Determined 255 MB as end of first partition
Thu Jan 1 00:00:17 1970 Calling mkpart for device: /dev/mmcblk0 and fs: ext4 with start 257M and end 100%
Thu Jan 1 00:00:20 1970 Calling fmtpart for partition /dev/mmcblk0p2 and fstype ext4
Thu Jan 1 00:00:32 1970 Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=2 blocks, Stripe width=1024 blocks
469568 inodes, 1877760 blocks
93888 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=1925185536
58 block groups
32768 blocks per group, 32768 fragments per group
8096 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632

Allocating group tables: 0/58 done
Writing inode tables: 0/58 done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: 0/58 2/58 done

Thu Jan 1 00:00:32 1970 Mounting root
Thu Jan 1 00:00:32 1970 Trying to mount to MNT_ROOT (/mnt/root
Thu Jan 1 00:00:32 1970 Using device.root: /dev/mmcblk0p2
Thu Jan 1 00:00:32 1970 Extracting files to root filesystem
Thu Jan 1 00:00:32 1970 Starting extract progress…
Thu Jan 1 00:03:33 1970 Extraction of root filesystem completed
Thu Jan 1 00:03:33 1970 Configuring bootloader
Thu Jan 1 00:03:33 1970 Configuring bootloader: moving /boot to appropriate boot partition
Thu Jan 1 00:03:34 1970 Configuring boot cmdline
Thu Jan 1 00:03:34 1970 Configuring /etc/fstab
Thu Jan 1 00:03:34 1970 Successful installation. Dumping log and rebooting system

You said that upgrading from the June update failed. I would like to see those logs.



Sadly I didn’t think to backup as I thought it was my fault somehow… I am building a clean 2015-06-01 install image now and will re-execute the upgrade process.

If it fails again in this way, what .log files would you like from the Fat32 partition on the SD Card or will you need files from the ext4 partition?

Again, thanks!


Should it fail, upload:


Just trying to work out what went wrong. Did you have any custom packages on your OSMC installation?


I ended up with a boot loop also when upgrading but only because I tried to do some cleaning also and did a apt-get autoremove which took to much.

I fixed it by watching journalctl and noticing it complaining about missing files. After reinstalling libx11-6 and libvorbisenc2 it started working again after the next loop.

Maybe some .deb dependencies got dropped along the way so now they’re not getting installed or even removed by autoremove after the fact since apt thinks they’re no longer needed.

You should not need libx11-6, just libvorbisenc. We have rebuild the Debs with the dependency on libvorbisenc2.



Yes it appears my osmc automatic upgrade from 2015-06-01 image was indeed caused by me on the first go, unlike shadow I didn’t check anything after the failure because indeed I had some custom packages (VNC Alpha 4 - worked fine), TightVNCServer (which I had removed using first “sudo apt-get remove tightvncserver”) and I used autoremove to clean up the “unneeded packages”.

I have 2016-06-01 installed again and am about to execute the upgrade process, I will post back with confirmation.

Sam & shadow, thank you for the assistance… greatly appreciated :smile:


Looks like despite work on ffmpeg patches to remove xcb support we do in fact need the package



I am pleased to confirm 2016-06-01 manual update to 2007-07-01 worked flawlessly (a bit slow)… I purposely backed up logs and settings at each stage just in case and didn’t bother configuring anything and all went properly…

I still need to shake out Isenguard Kodi 15.0 addins and such but I expect all will be fine (or fixable from SSH at least) :smile:

Thanks again for the assistance!


Good to hear