Newest update seemed to have broken my remote


I have a RC6 remote and in the past pressing a remote button causes a repeat press. It was away until I installed the newest update. The issue is now back and I can’t get rid of it. I even tried the startup script but nothing. Any way of fixing it?

Search the forum there had been multiple threads for that topic in the last days.
Quick answer configure your remote correctly in MYOSMC remotes

I did… I even tried ever remote listed in my osmc.

That’s very odd, they removed the repeat keypress issue for the RC6 remotes by disabling the RC6 kernel decoder. Theoretically the newest update, selecting your RC6 remote in the my osmc, should have produced only single keypress results.

Run an lsmod and see if ir_rc6_decoder is in there still? the newest update was supposed to blacklist that module.

I switched to a pc-remote ir receiver I bought for $5.00. works fine

You can also just re-enable the module, if you are not getting presses from LIRC. This simply means a profile isn’t defined for your remote yet. The proper solution would be to use irrecord to create a profile, but the simpler one would be to remove the blacklist