Newly formatted drive has used space already?

So I formatted an external 8TB drive as ext4.
Did a reboot.
Then checked on it and got this:

osmc@osmc:~$ df
Filesystem           1K-blocks     Used  Available Use% Mounted on
devtmpfs                774712        0     774712   0% /dev
tmpfs                   899232    16868     882364   2% /run
/dev/vero-nand/root   14499760 10223996    3516164  75% /
tmpfs                   899232        0     899232   0% /dev/shm
tmpfs                     5120        0       5120   0% /run/lock
tmpfs                   899232        0     899232   0% /sys/fs/cgroup
/dev/sda1           7811937256    94236 7811826636   1% /media/Seagate 8TB 3
tmpfs                   179844        0     179844   0% /run/user/1000
osmc@osmc:~$ sudo tune2fs -l /dev/sda1 | grep 'Reserved block count'
Reserved block count:     0
osmc@osmc:~$                                                                                                                                              

I know it’s small, but any ideas why this would be?

Ext4 is a journaled filesystem and by nature quite complicated. That are reserved blocks
https://wiki.archlinux.org/index.php/Ext4#Reserved_blocks

Just like with any filesystem, there is built in overhead. You will see the same with BTRFS, NTFS, FAT, etc.

1 Like

None of the other drives I have formatted with ext4 have done that.

I just formatted an unused 4TB drive that I had handy with EXT4.

/dev/sdb1                           3844628496      69636 3649193332   1% /media/brian/f5011889-aadb-40a0-bf1a-d835cbe411d6

or for more human readable

/dev/sdb1                            3.6T   69M  3.4T   1% /media/brian/f5011889-aadb-40a0-bf1a-d835cbe411d6

So that’s totally normal for EXT4.

And just for fun, the same drive formatted with NTFS:

/dev/sdb1                           3906982908     185216 3906797692   1% /media/brian/692CC38B6FFF6444

or

/dev/sdb1                            3.7T  181M  3.7T   1% /media/brian/692CC38B6FFF6444

And more fun, reformat the drive as exFAT:

/dev/sdb1                           3906982912     123392 3906859520   1% /media/brian/BB05-2DAD

or

/dev/sdb1                            3.7T  121M  3.7T   1% /media/brian/BB05-2DAD
1 Like

Cool.
Weird that on other drives I have done as ext4 I have had 0% used after formatting.
Maybe I used some crazy settings on those previous formats.
But thinking about it now I don’t see how that would be possible.
Probably just me remembering incorrectly.
I’ll be formatting a different drive to ext4 tomorrow night so I’ll see what that one does.

We’ve had a longish exchange of words regarding reserved space etc. in this thread starting (for me) at Best HDD format for Vero 4k+? (And how to do so!) … till the end.

Just did another drive and same thing.
I must just be an idiot and remembered incorrectly with the other drives I’ve done.

2 Likes

So now I need to change the drive label.
I tried e2label /dev/sda1 <label> and it didn’t give me an error or confirmation but then I checked and the label is still the same.
Am I missing something here?

Never mind, the change showed up after a reboot.