NFS folder access problem

Where are your movies? /Multimedia?


When you mount it, you should be able to use:


You may want to consider using fstab or autofs mounts instead of Kodi mounts as they will perform better.

I think I have proven the issue is with the NAS, I’ve just created a shared test folder and it seems to be working. I have tried all options with other shared folders and matched settings with the test folder but it still will not allow access?

I’ll try another reset on the NAS and create all the folders again to see if that works. Thanks all for your help!

I’m not familiar with fstab or autofs so I’ll read up on it! Thanks for the suggestion.

If you consider switching to system mounts, I’d suggest autofs. It’s more tolerant of network issues and server reboots.

Irrespective of whether you end up using fstab or autofs, you can still try to mount the share interactively from the command line using the -v (verbose) option:

sudo mkdir /mnt/multimedia
sudo mount -v -t nfs /mnt/multimedia

(If you’ve already created a mount point, skip step 1 and use it in step 2.)

Thanks for the advice!

I still cannot get the NFS share to work using Kodi even after I’ve reinitialised my QNAP NAS… complete factory reset and wiping the drives and the problem still persists? Every other Kodi client I have on the network is able to mount the NFS from within Kodi. Really strange why it’s only the Vero that has this problem. I’ve never had this issue in all the years using Kodi?

I’ll give fstab / autofs a go and see if it works.

Did you try manually mounting as @dillthedog suggested? That’s the best way to track down the problem.

1 Like


I’ve tried mounting with autofs but I’m struggling as I’m a noob when it comes to linux command… I’ve followed the info in the link @bmillham sent:

I have got as far as:

First install the autofs package
“sudo apt-get install autofs”

but once I type this command:

edit auto.master
“sudo nano /etc/auto.master”

I don’t know what to do… I typed in " /- /etc/auto.nfs.shares --timeout 15 browse" but don’t know where to place it in the text and how to save?

Also after typing “sudo nano /etc/auto.nfs.shares” I don’t know what to edit the following to: “/mnt// :</path/to/share1>”

Any help would be appreciated. Thanks!

The instructions are clear on this:

and add

 /- /etc/auto.nfs.shares --timeout 15 browse

to the end of the file

As to saving, nano shows at the bottom of the screen the various commands. CTRL-O to save, CTRL-X to exit.

/mnt/<server1>/<share1> <IP of server1>:</path/to/share1>

If you server is named myserver.local and the share is /nfs/myshare and you want in /mnt/Movies:

/mnt/Movies myserver.local:/nfs/myshare

You can replace myserver.local with its IP address instead.

I’ve managed to mount the multimedia shared folder and I tested it with “ls -lah /mnt//” and it details all the folders within Multimedia.

Thanks for you help with this!

In order for Kodi to scrape videos do I just access the NFS via the normal method of ‘add videos’ then select NFS?

Is autofs running in the background on the Vero now or do I have to enable it?

No problem, I’m glad you got it working!

Add the folders in Kodi as /mnt/Movies (for example). Use the share names like you set them up in autofs.

Yes, autofs is running automatically. The shares will be mounted when accessed.

Do I do this by selecting ‘Add Videos’ then ‘Browse’?

It’s OK I just found it in ‘Root’ then ‘mnt’. Cheers

1 Like

Going back to the initial problem I had at the start of this thread with not being able to access folders within the share, I’ve just typed in

‘ls -lah /mnt/QNAP/Movies/Test’

and it states:

'ls: cannot open directory ‘/mnt/QNAP/Movies/Test’: Permission denied.

This is a folder I have created today via the QNAP NAS QTS interface and I’ve ensured all user permissions are set to Read/Write and that NFS is enabled for the Multimedia share. I can open other folders in the share just not recently added ones.

Also this same ‘Test’ folder can be accessed via my NUC running latest release of LibeElec.

So the problem still persists with the Vero!

It’s not the Vero, it’s a permissions problem on the QNAP. Do you also have execute permissions set on the folder? With linux (that’s what I assume that the QNAP is running) you have to have execute permissions set to access a directory.

Do you mean execute permissions per client on the LAN. Would that explain why the LibreElec NUC can access the ‘Test’ folder?
I’ve checked all permissions for my only user ‘admin’ and R/W is selected for all shares and NFS is allowed for all clients on the LAN.

I don’t have your NAS, so I don’t know exactly what options it allows. Maybe someone else here has one that they can help you with its setup.

It’s definitely a permission problem, just confused as to why some clients can access ‘Test’ folder but some can’t. I’ll do some digging re the QNAP, something isn’t quite right with it. It seems that newly created folders within a share are not automatically being set with the same permissions as the main Share folder. I’ll see what the QNAP forums say.


Do you have command line access to the QNAP? If you can SSH in you could try to manually set the permissions. Something like:

chmod -r 777 /path/to/Test

may fix it. But I don’t know if the QNAP would change it back.