NFS Issue: Cant find network drives

Hello there, this is my first time posting and I’m a fairly new to OSMC and RPi, I have had some experience with XMBC on an old ATV2 thru FireCore but its been a few years.

Anywho, so I loaded OSMC RC onto my new RPi 2. Im trying to point it in the direction of my Apple Time Capsule which has media on both the internal and a connected external drive with no luck thus far. The TC and RPi2 are both connected hardwired on the same network with nothing but an unmanaged switch between the two. When I try to connect the the drive thru Video>Files>File>AddVideos>Browse>NetworkFilesystem(NFS), it just displays a “Busy Please Wait” dialog that goes away and it seems doesnt do/find anything. As an alternative I have also tried the WindowsNetwork (SMB) option in the same submenu and it yields an “Error 2: share not available” dialog box. Lastly I attempted to “AddNetworkLocation” manually as a NFS having known the IP and login credentials of my TC, but then a dialog box pops up that says “Unable to Connect Could not retrieve directory information. This could be due to the network”

So this is where Im still at. I have no existing experience SSH’ing into the RPi2 but I was reading on it some this morning and am a quick learner. Any help would be appreciated.

I also has this problem. It was working fine on my RPi model B, untill I reinstalled RC1 on RPi2.

Okay, so I followed this guide, for adding additional attributes to NFS shares. I have a QNAP NAS.

What is weird, is that is the access was OK with the OSMC installation on the RPI model B.

ssh into osmc and run:

showmount -e your_nas_IP

it should list all NFS shares from your NAS.
Not all listed shares may be used due to IP/access restrictions.

So you should also check:

  • allowed IP addresses on your NAS share
  • if your RPi IP address is on the allowed IP list for the selected share (did it change from your old installation ?)

Hi @voytacs,

Do you found a solution ?

It’s the same for me…

Same here…

This last try worked for me. But, I still can not backup my system… Still looking for a solution.