NFS Mount

Hello,

Unfortunately i have a new problem - i cant mount my Synology-NAS share as an media source.

I try the same way I’ve added the share many times on other Kodi devices:
Add source -> NFS -> NAS-IP -> Media-Share
But at this point i cannot “enter” the Media-Share.

I have already added NFS permissions to Vero’s static IP, disabled the Synology firewall and even reset my NAS…

Is there anything special to consider at Vero / OSMC or differently than with other Kodi devices?

Thanks in advance!

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for all components

  • enable event logging and notification event logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

Hello,

i have created a log: https://paste.osmc.tv/digehepuxa

Thanks for checking!

Hi,

Failed to open(//) opendir call failed with “NFS: READDIRPLUS of / failed with NFS3ERR_ACCES(-13)”

Have you nfs4 enabled? if so try disabling it?

You may want to consider addings nfs shares as follows:

Thanks Tom.

Thanks for checking Tom!

Could you tell me how to check if nfsv4 is enabled and how to disable?

Hi,

On DSM 6.2.3-25426, its located:

Control Panel -> File Services -> SMB/AFP/NFS

Under the NFS Section, below the Enable NFS tickbox, there is another tick box Enable NFSv4.1 support; if its ticked un-tick it.

Thanks Tom.

Thanks Tom!

NFSv1 is not enabled on DSM.

I have followed the instructions to mount the share via autofs and the share is mounted in the filesystem afterwards:

osmc@osmc:~$ mount | grep Vol1
/etc/auto.nfs.shares on /mnt/NAS/Vol1 type autofs (rw,relatime,fd=6,pgrp=2468,timeout=15,minproto=5,maxproto=5,direct,pipe_ino=16686)

But i can only list the content with sudo:

osmc@osmc:~$ sudo ls -lah /mnt/NAS/Vol1
drwxrwxrwx  12 root root  4.0K Apr 30 19:22 .
dr-xr-xr-x   3 root root  4.0K Jun 19 14:07 ..
drwxrwxrwx  24 1024 users 4.0K Jun 14 16:26 <Foldername>

not as user osmc:

osmc@osmc:~$ ls -lah /mnt/NAS/Vol1
ls: cannot open directory '/mnt/NAS/Vol1': Permission denied

In the osmc GUI i can also not enter the share. Is there a user / permissions issue and i have to do something on the Synology? This are the current user:

admin@DS418j:/$ cat /etc/passwd
admin:x:1024:100:System default user:/var/services/homes/admin:/bin/sh
anonymous:x:21:21::/nonexist:/usr/bin/nologin
avahi:x:84:84::/:/bin/false
bind:x:53:53::/:/usr/bin/nologin
daemon:x:2:2::/:/bin/sh
dbus:x:81:81::/:/usr/bin/nologin
dovecot:x:143:143::/dev/null:/usr/bin/nologin
FileStation:x:179652:179652::/var/packages/FileStation/target:/sbin/nologin
Flo:x:1026:100::/var/services/homes/Flo:/sbin/nologin
ftp:x:21:21::/nonexist:/usr/bin/nologin
guest:x:1025:100:Guest:/nonexist:/usr/bin/nologin
http:x:1023:1023::/var/services/web:/bin/false
ldap:x:439:439::/var/lib/openldap:/usr/bin/nologin
lp:x:7:7::/var/spool/lpd:/bin/sh
mysql:x:66:66::/var/services/mysql:/bin/false
nobody:x:99:99::/:/bin/false
ntp:x:87:87::/var/lib/ntp:/bin/false
OAuthService:x:226662:226662::/var/packages/OAuthService/target:/sbin/nologin
postfix:x:125:125::/dev/null:/usr/bin/nologin
postgres:x:55:55::/var/services/pgsql:/bin/sh
root:x:0:0::/root:/bin/ash
rpc:x:32:32::/dev/null:/bin/false
SynoFinder:x:195341:195341::/var/packages/SynoFinder/target:/sbin/nologin
system:x:1:1::/usr/syno/synoman:/usr/bin/nologin

Thanks in advance!

Hi,

Assuming that’s a typo? As it should be NFSv4.1.

Sounds like a permissions issue server side, What settings do you have for Privilege & Squash for nfs permissions on the synology?

Thanks Tom.

YEAH!!! :slight_smile:
For this export i have now assigned all users to guest via Squash and it works now! I dont know why this is not necessary for the other exports but it doesn’t matter, it works now - Thank you!!!

2 Likes