NFS mounts suddenly failing?

#1

I’ve been using NFS shares from a Windows 10 PC for quite a while now (Hanewin nfsd).

It has suddenly decided to stop working. I have tried connections on wireless and wired (usual connection).

I have disabled the firewall to no avail.

I get the sad face or a complete crash when trying to play media and the scan on startup just sits at 0%.

Disabling the firewall momentarily showed the first frame of a video but then crashed again.

None of the media I’ve played has issues, indeed previously played media also doesn’t work.

I have Kodi installed on a FireTV stick in another room accessing exactly the same files and shares and it has no issues.

The logs are here https://paste.osmc.tv/epakumagaz please ignore errors like this as I’ve recently moved a drive but not updated the share:

ERROR: NFS: Failed to mount nfs share: /music01 (mount/mnt call failed with "RPC error: Mount failed with error unknown mount stat(19) Numerical result out of range(34)")
21:25:11.805 T:3707761408   ERROR: GetDirectory - Error getting nfs://192.168.1.65/music01/Music/(hed) Planet Earth/(hed)pe/

Thoughts?

0 Likes

#2

So it’s only that one file that fails? Try copying it directly to the Vero and see if it plays then.

If it does not play, please reboot the Vero twice, that will clear all of the previous errors and may help see what’s really happening. Then play and post logs.

0 Likes

#3

No, none of the files works as you quoted. I can select a file, get the spinning icon and then a sad face. In fact when I turned on debug I also got a sad face when navigating back to the main screen. And as already said it is unable to do it’s startup scans to refresh the library.

0 Likes

#4

I appreciate the swift reply but I stated exactly what the issue is and posted the logs.

0 Likes

#5

Um, what I quoted is very confusing as you say it plays, and also doesn’t play…

Tells me that everything you played works, but

Tells me it doesn’t.

Which is it?

0 Likes

#6

Could you reboot twice and post logs again after trying to scan?

0 Likes

#7

Also, this confuses me, it starts to play?

Have you tried rebooting the WIn10 machine?

0 Likes

#8

Have you tried to mount one of the shares manually?

sudo mkdir /mnt/vid1
sudo mount.nfs 192.168.1.65:/video01  /mnt/vid1
0 Likes

#9

Did you recently update Hanewin?
I vaguely recall a new setting that needed to be observed.

0 Likes

#10

@Paul_Solecki I assume this is the topic @sam_nazarko had in mind

1 Like

#11

@sam_nazarko @fzinken that NFS issue seems to have cured it :man_shrugging: Strange that the 17.6 Kodi install on the FireTV Stick is fine without those settings.

However I’ve discovered a problem file which I’ll get more details on later. The file plays fine in MPC-HD, but will give it a go on the FireTV stick and do some further diagnosis and raise as a separate ticket :slight_smile:

Thanks folks!

0 Likes