NFS share in FSTAB not being mounted on boot


#1

Hi there,
I’ve discovered that my NFS share that I mount in FSTAB no longer gets mounted on boot/restart of the Vero.

It does however mount without errors as soon as the share gets accessed through Kodi.
Or if manually mounted with command “sudo mount -a”

The issue came to my attention when I did a restart of the Vero and very briefly caught a glimpse of the console output and noticed the error messages in red.

I did a test with rebooting the Vero and not accessing the share from within Kodi and then verified with command “sudo systemctl status mnt-media.mount” that the mountpoint was indeed not active.

So I began to investigate further and from going through journalctl it seems to me that systemd tries to mount the share before conmand is bringing up the eth0 interface, i.e. there is no network connectivity and therefore the mount obviously fails.

Could someone confirm that this is the issue or help me out with finding out what could be wrong here? Thanks in advance!

My entry in FSTAB:
192.168.0.120:/media /mnt/media nfs noauto,x-systemd.automount 0 0

Output of findmnt command:
http://paste.osmc.io/pejipifonu.1c

Output from grab-logs -A:
https://paste.osmc.tv/oyekurageh


#2

Look also in the GUI->MyOSMC->Network menu and try “wait for network” for the wired config.


#3

Thanks for the quick reply.
I’m a bit puzzled though, since I followed the guide with the options as described here, I was under the impression that option “noauto” was best practice?


#4

That is correct, you normally want noauto when using x-systemd.automnount as systemd will handle the mounts on demand.

Do as @JimKnopf suggested and set ‘wait for network’. That should clear up the errors while booting.


#5

I can confirm that the mount now works on boot without any errors after enabling “Wait for network” as suggested by @JimKnopf

Thank you for your assistance, much appreciated!