NFS Shares mounted via /etc/fstab do not update MariaDB

Hello OSMC Community!,

Long time reader, first time poster :slight_smile:

  • I have NFS shares exported with media from a server with TV media content present in the directories.

  • They are mounted on osmc via /etc/in the following way

192.168.0.107:/TV2 /home/osmc/TV nfs noauto,x-systemd.automount 0 0 
  • The plays media fine via kodi through Videos → files GUI option.

  • I defined them in sources.xml as per the following

<?xml version="1.0" encoding="utf-8"?>
<sources>
    <programs>
        <default pathversion="1"></default>
    </programs>
    <video>
       <default pathversion="1"></default>
      <source>
           <name>TV</name>
            <path pathversion="1">/home/osmc/TV</path>
            <allowsharing>true</allowsharing>
        </source>
  </video>
</sources>
  • My advancedsettings.xml is configured as per the following:
<?xml version="1.0" encoding="utf-8"?>
<advancedsettings>
	<videolibrary>
		<importwatchedstate>true</importwatchedstate>
		<importresumepoint>true</importresumepoint>
	</videolibrary>
	<videodatabase>
		<name>videos107</name>
		<host>192.168.0.107</host>
		<user>xxxxx</user>
		<pass>xxxx</pass>
		<type>mysql</type>
		<port>3306</port>
	</videodatabase>
</advancedsettings>
  • Kodi has created the DB as expected: (videos107)
MariaDB [(none)]> show databases;
+--------------------+
| Database |
+--------------------+
| information_schema |
| mysql |
| performance_schema |
| videos107 |
+--------------------+
4 rows in set (0.02 sec)
  • However,no information is being updated into the database (yes I have update library on startup enabled) as per the below:
MariaDB [(none)]> use videos107;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
MariaDB [videos107]> select * from tvshow;
Empty set (0.00 sec)

MariaDB [videos107]> 
  • Why is kodi not populating the TV show data into the database?

I can watch the media fine via the Video → File sources, but I do not get the expected "TV " tab with the latest added shows etc. Yes I have set the media content to TV on the source path.

Please assist?

My guess would be how you have your directories setup. It should be:

TV Show Name
-> Episode S0xE0x

etc.

Look on the Kodi wiki for more information about naming TV episodes.

Apologies for the bad formatting originally, sorted it out now so the post is clear :slight_smile:
Thanks.

Thanks bmillham

My naming conventions is

<TV Show Name>/<Season x>/Episode.Name.S01e01.mkv

That should work, so next thing would be logs. Run a scan and then upload the logs. (we really only need the Kodi log, but go ahead to do all of them.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thanks, ill gather that info now and reply back asap.
Really appreciate your fast responses :slight_smile:

Another question, have you manually tried the scan, or only using the auto on start option? If that’s the case, make sure in MyOSMC that you have ‘Wait for Network’ enabled.

Yes, i have manually tried the scan and also have wait for network enabled

Cheers :slight_smile:

Debug logs as requested :slight_smile:

https://paste.osmc.tv/vonacirebo

edit sorry, i had a different advancedsettings.xml (playing around) in the original log report. Changed it back and re ran the grab-logs -A. Please use this updated url which reflects the problem properly.

You are getting a 401 authentication error. Make sure that your system is up to date, and that the TVDB scraper is up to date.

Thanks again
doing this now.
Will report back ASAP.

Cheers :slight_smile:

Thanks bmillham,

I performed the following on my osmc device

#  sudo apt update
#  sudo apt full-upgrade

Updated the “The TVDB” addon via the osmc gui
It now says that “The TVDB” addon version is 3.0.14

Rebooted my osmc device.

Unfortunately the problem persists.

New debug logs here:

https://paste.osmc.tv/tedewutevu

I can still stream the video files via Video -> File sources

Have you assigned a scraper to the source and configured it? That info is stored in the database, so we can’t see it from logs.

You can find the info with the following SQL statement:

SELECT strSettings FROM path WHERE strPATH = '/home/osmc/TV'

Hi nabslt,

It was late last night (4 am ish) and I swear I had configured that but I must have missed it :frowning:
It is now working as expected.

A huge thanks to bmillham & nabslt.

Your unbelievably fast replies are so much appreciated.

God bless you both.

Cheers.