No access to NAS, ever

Hi there!

I have installed a NAS, a Synology DS224+. It’s my first NAS, and I’m not very good at computer-things.
My old eGreat mediaplayer, I managed to get working with both my computer AND my NAS, but my Vero4K, that’s another story. It works just fine with my computer, and with the latest update I got the sound back as well. It “went missing” for a little while, but works fine now.
The NAS, however, I just can’t get access to. I can find it via SMB, and with NFS, but I keep getting “operation not permitted”. Why is that, and how do I “get permit”?


You might check the NFS permissions on the shared folder of the NAS. It might be that NFS is installed but didn’t add this to the shared folders

Below an example of my settings, i also use autofs.

I’ve permitted everything I possibly can permit, and still the same “operation not permitted”.
Can it be something in Kodi that blocks me? I do get in with my older eGreat.player.

So the ip address of the vero is added to the share on your nas as in the example?

Check out this article as well…

Let me check again.

Yep, it’s there.

When I try with Samba and reach the catalogs on the NAS, I can’t click on them, nothing happens. The only thing I can do is abort or back out.

you could try follow this guide.

works both for Samba or NFS.

there are also reports about passwords file:

ther might be old information in your passwords.xml

SPNEGO login failed: The attempted logon is invalid. This is either due to a bad username or authentication information.

You could try rm /home/osmc/.kodi/userdata/passwords.xml and then try to connect again but be carefull if you use this file and info in ot also for other area’s.

Check as well the SMB version on NAS and Vero, the need to be the same. SMB V1 is not secure anymore.

I’m sorry guys, but that is way beyond my knowledge. I’m glad if I can get Samba to work.
The question is why it don’t. I’ll se if I can remove any old passwords.

Passwords removed, but still no access. I can tap on the catalogs, but there’s no reaction, nothing happens. This in NFS, in Samba I still hav’nt permit.

It sounds like a version discrepancy in SMB. I don’t know if the Vero has SMBv1 installed any longer due to security concerns. You may need to enable v2 or v3. I had to do that on my QNAP NAS to get it to work.

SMB Settings | SMB Service - Synology Knowledge Center

Hi @Penke62 ,

I have a Syno DS223 and use NFS but perhaps I can help.

I assume you have a share on the Synology and you want to access it with the OSMC device using the mediacenter’s SMB stack:

  1. Check whether your SMB settings on Synology are defaults. Here is, how it looks like on my system. WS-Discovery is important to be active!

  1. If you want to use smb guest login (and that is what I understood from your description), you need to activate the guest user on the Synology which is deactivated by default.

  1. In the OSMC GUI, go to Settings → Services → SMB CLient and reset the the settings to default. If asked, restart the mediacenter.

That’s it! Of course on the Synology you need to allow access for user guest to the shares which should be used.

But using the guest login means, everybody in your intranet accessing the NAS as this user can see what you share. More secure is to use a specific user and password

Let’s assume on the Synology

  • you have a share named ‘video’
  • a user ‘Holger’ was configured to have read access to this share; the user has a password

In the mediacenter you can setup the smb access as follows:

  1. In the OSMC GUI goto Videos → Files → Add Videos → Browse → Add network location (at the bottom)

  1. Fill in the values. Use SMB as protocol, the DNS of your Synology, leave out the shared folder, set the user and password

  1. When done, you see a new item in the list presenting your synology and you can use that to browse to your path you want to use

Let us know, how far you get with this information. This isn’t rocket science.

1 Like

NAS has SMB1, SMB2, SMB2 and large MTU and SMB3 activated.

So, is the guest user activated on the Synology?

It wasn’t, but is now. Still the same, not permitted with Samba, and no action with NFS.

if you’ve done and checked the first 3 steps of my post above, I’m running out of ideas, why smb access is not working :man_shrugging:

Ok, smb ist not successful although it should with the settings above and you have removed the passwords.xml.

Before suggesting to restart the kodi configuration from scratch, let’s try the nfs part:

  1. On the Synology check whether you have set the file service NFS as follows but replace the domain name with the domain you use for your intranet; typically you set/find this in your router web GUI.

  1. The share you want to reach with the OSMC device should have a similar configuration like shown below, so edit the NFS rule accordingly:
  • hostname: use (read from your NFS screen shot above)
    Explanation: This allows access for ALL clients in ip range 192.168.2; 24 is the CIDR notation of the subnet mask

  • Privilege: Either read/write or read only

  • NFS works user based but typically there is no user osmc on a NAS; choose map all users to admin so any file access gets the privilege of the NAS admin user

  • Security: sys or AUTH_SYS is the default, so NFS uses the client’s user name and group. Leave it that way.

  • Enable asynchronous IO: Allow parallel IO and prevent ping-pong IO. Enable this in any case!


That’s it with NFS. You should now be able to use the browse for new share menu and use the Network File System (NFS) item in the mediacenter.

I really can’t say what has changed, but now it seems to work with samba. I’m done for the evening, and will restart everything again tomorrow, but it looks promising.

1 Like

Well, might be the Synology has cached something and the smb service on the Synology wasn’t restarted since no configuration change. Look at the first picture of my first post, you’ll find a clear cache button somewhere.

Sounds good; keep us informed. :+1: