No addons can be installed after fresh install

Raspberry Pi 3, installed latest build. It’s a reinstall on a Pi box which has worked for a couple years.

The reinstall went fine, but every addon attempt says installation failed. I’ve tried checking for updates in the Add-on Settings, reboot, etc. It downloads fine but doesn’t install; the kodi.log has lines saying “Hash mismatch after download”: This is representative of every addon installation attempt - every one I’ve tried does this.

2021-08-01 09:40:13.510 T:1581240544 DEBUG: CCurlFile::Open - effective URL: http://ftp.fau.de/osmc/osmc/download/kodi/addons/leia/service.subtitles.opensubtitles/service.subtitles.opensubtitles-5.0.16.zip?sha256
2021-08-01 09:40:13.510 T:1513541856 DEBUG: Thread FileCache start, auto delete: false
2021-08-01 09:40:14.280 T:1581240544 DEBUG: Resolved addon path http://download.osmc.tv/kodi/addons/leia/service.subtitles.opensubtitles/service.subtitles.opensubtitles-5.0.16.zip to http://ftp.fau.de/osmc/osmc/download/kodi/addons/leia/service.subtitles.opensubtitles/service.subtitles.opensubtitles-5.0.16.zip hash PK �))J�a�^� $ - service.subtitles.opensubtitles/changelog.txtmT]o1|��7����ByL
2021-08-01 09:40:14.285 T:1513541856 DEBUG: Thread FileCache 1513541856 terminating
2021-08-01 09:40:14.732 T:1581240544 DEBUG: CurlFile::Open(0x6ea721e8) http://ftp.fau.de/osmc/osmc/download/kodi/addons/leia/service.subtitles.opensubtitles/service.subtitles.opensubtitles-5.0.16.zip
2021-08-01 09:40:15.910 T:1581240544 ERROR: CAddonInstallJob[service.subtitles.opensubtitles]: Hash mismatch after download. Expected PK �))J�a�^� $ - service.subtitles.opensubtitles/changelog.txtmT]o1|��7����ByL, was ca9a93275ae73f0601dd86e26a4041a5e9240c0268abb7baf3f339818cafa030

What’s going on?

The same thing is happening on the Vero, Sam will be working on it soon.

Similiar issue here.
I’m new to OSMC (since today). I did a fresh install on my RPI3 and if i choose Install from Repository i only get the error no connection to Repository.
Did a fresh install on my RPI1 with the same result.

Maybe related to:

It seems one of the Devs will have a look into this…

I’m already working on it.

3 Likes

This should now be resolved. Please see: Could not connect to repository - #13 by sam_nazarko for details

Thanks for your understanding

Sam

3 Likes

Thanks a lot for fast fixing!