No Addons found in OSMC

Hi,

I am new to the raspberry pi and OSMC. I have raspberry pi 3, I have installed Noobs on it and then installed OSMC via Noobs. When I started OSMC it asked me to update it, I did the update and rebooted the OSMC. Now I can see my OSMC is connected to internet. I SSH into OSMC and pinged google.com, it worked. But when i got to videos -> Get Video Add Ons I dont see anything there, same with music add ons. Please help.

You may have to update the kodi repository. Go to addons, choose the kodi repository, open context menu and choose update.

Try refreshing the repository, there was a mirror issue for about 5 minutes today

I am not able to find Kodi repository under add on.

Settings → Add-ons → Install from repository → Kodi Add-on repository
If you don’t have that you would have a problem of your system and would need to reinstall

Or just run:

sudo apt-get --reinstall rbp1/rbp2/atv/vero/vero2-mediacenter-osmc

Thanks @fzinken and @sam_nazarko I have reinstalled OSMC and it worked. But still there is no Kodi repository. :slight_smile: