No audio after August update with Vero 4k

No audio either over analog nor HDMI.
Before the update I used HDMI audio on my LOEWE bild 1.32 TV. Nothing on the hardware configuration was changed, I just installed the update from a SD card.

I tried the tips from this topic without success:

PDF with specs for the LOEWE TV:

Vero Log file:

Please advice.

Try to change

Play GUI sounds: Only when playback stopped
Allow passthrough: True
Adjust display refresh rate: On start / stop
Sync playback to display: False

and after that: Enable Dolby Digital (AC3) transcoding (every multichannel audio will be transcoded to AC3 and forwarded your TV which supports AC3).

Thank you for your replies, but I’m afraid your suggestions didn’t help; still no audio.

And just in case I didn’t made this clear, it is not only the HDMI that has no sound, the analogue audio is also not working. Tried a headset and some old PC loudspeaker on the analogue output (of course I tried it with the two different “system - audio - audio output device” settings).

New log file, just in case:

Edit: for testing purposes I installed the previous version, and it had HDMI and analogue sound right from the installation.

2021-08-21 16:34:42.995 T:2557     INFO <general>: VideoPlayer::OpenFile:

Could you place this file on an USB stick/hdd and try to play it directly from the local drive?

Your “emby” plugin has an issue, not sure whether this is realated

2021-08-21 16:23:25.324 T:2771    ERROR <general>: ERROR: EMBY.core.HTTP: [ 500 response ]
2021-08-21 16:23:25.328 T:2771    ERROR <general>: Exception in thread Thread-4:
                                                   Traceback (most recent call last):
                                                     File "/usr/lib/python3.7/", line 917, in _bootstrap_inner
                                                     File "/home/osmc/.kodi/addons/", line 134, in run
                                                     File "/home/osmc/.kodi/addons/", line 394, in get_fast_sync
                                                     File "/home/osmc/.kodi/addons/", line 462, in fast_sync
                                                   TypeError: 'bool' object is not subscriptable

Don’t see this enabled:

<setting id="audiooutput.ac3transcode" default="true">false</setting>

The problem was that “Audio - Stereo Upmix” was set to false.
And even though the log says that the default for this setting is “true”, I’m 99% sure that I hadn’t set it to false. And maybe I’m misunderstanding something, but since my TV has only 2.0 channels I don’t think there is a need to upmix any of my media.

Anyway, the first time I installed the new version I did so from an SD card, and I think with that method the internal memory of the Vero gets completely wiped. So any of my old setting would’ve been deleted.

My second installation was the last Kodi 18 version from 2020, again from an SD card, and that version had sound from the beginning - no need for me to change any audio settings. It just worked with the default settings.

The third, and now working installation, was done with the update function of MY OSMC. And to my surprise this keept all settings, and even updated most add-ons to new version which work with Kodi 19.
But again, no more sound.

I tried playing a simple MP3 from a USB stick, as you suggested, and with headphones in the analogue jacket I could hear very very VERY faint sound at max sound volume.

Since this was encouraging, I played a bit more around with the settings and randomly enabled “Stereo upmix”.

So, audio works again.