No audio, even after reboot


The Vero 4K had no audio today, even after a reboot. After I switched the AVR to another source and back again it started working again.

I think likely the Vero 4K was at fault since the AVR is otherwise rock solid. Here is the log if anyone can offer an insight:


Is this a one-off, or reproducible?

One-off. It did persist after a reboot though, which I thought was weird and hence why I posted.

Same problem here, hdmi audio works, but 3.5mm jack is silent event after reboot.
Here are my logs:

If there’s anything I can do to test, just let me know, thanks

Are you sure it’s silent? The signal level is quite low and it’s not designed to power headphones. Try plugging in a powered speaker.
Just checking - the audio jack is the one nearer the ethernet port.
If still no joy,

sudo apt-get install alsa-utils

This will show you the volume and mute controls which may be wrongly set.

Thanks grahamh for your suggestions, everything seems to be loud enough and I’m using jack nearer ethernet port. I managed to get this working by reseting audio settings to defaults (Settings->System->Audio->Reset to defaults).
There’s one strange thing I want to share. Originally my vero 4k was meant to stream audio to the speaker via bluetooth. I followed your guide for installing bluetooth support and installed a2dp-app-osmc. Bluetooth did not work so I moved to 3.5 jack, but in audio settings I’m now having audio output -> playback/recording thru Pulseaudio server. And this option exacly has to be chosen to hear any sound from 3.5 mm jack. If I select the other option (AML-M8AUDIO/HDMI) there is no sound at all coming from the speaker.

Thanks for that report - I think I can fix that device selection issue but not right away. Meanwhile, you should keep channels set to 2.0. (You had it on 2.1 before). If you uninstall the a2dp package sudo apt-get remove --purge a2dp-app-osmc and re-boot, analogue audio should work whichever device is chosen (PCM or HDMI) and also play the front channels even if you are playing multi-channel stuff through HDMI.

Alternatively, you might want to have another go at BT. @fzinken seems to know the trick.

Thank you grahamh for your suggestions, I’d be very pleased if @fzinken can point me into a direction with BT audio.

Well after the latest OSMC update it should “just work” after installing a2dp.
So what was your problem? Pairing?

Okey, I’ve unistalled a2dp-app-osmc package as grahamh suggested, but after reboot I’m still able to choose Playback thru PulseAudio server. I’ve also tried to setup BT audio, but with no luck. Pairing is successfull but no sound comes from the speaker. By ‘installing a2dp’ you mean a2dp-app-osmc @fzinken ? Thanks

Yes, but strange that you remained Pulse after removing it. Did you autoclean?

I think that wording is in kodi somewhere and may not get cleaned even by a purge.

So I reinstalled a2dp-app-osmc, rebooted, ran sudo apt-get update rebooted again, but I’m unable to pair my speaker(LG SJ6). I’m attaching logs:
Thanks for your help guys

If pairing via MyOSMC fails you might want to try via command line.

Amazing, pair via commandline works well. I even managed to connec tia gui for the second time (after the device was paired and set as trusted). One last thing that comes to my mind, is there an autoconnect feature? thanks

Yes, for me the speaker autoconnects as soon as I switch it on. So as long as you keep the pulseserver as audio sink it will autoswitch as soon as bluetooth speaker is connected. The only downside is you need to life with the slight delay in audio which is mainly hearable in navigation

thanks to you both for helping, my speaker does not autoconnect now, but I have to investigate further, this is not a big issue. I suppose that this delay is because of wifi/BT share the same hardware or maybe frequency, isn’t it? I have a usb powered 3.5 audio jack -> BT adapter(you plug the jack and it emits the signal by BT), which I also tried and there’s no (noticable) delay in audio, so it has to be something connected to the internal BT. In the next couple of weeks,I’m getting new wifi router (dual band 2.4/5 Ghz), so I’ll see and reply, how this affects the delay.

No the delay is caused by pulseaudio

Is there a reason for that? I’m just curious. I tried to play 2 different videos and the delay was different each time.

the processing time of pulseaudio

For Videos I don’t have any impact.