No audio from AAC LC 32kHz tracks

I’m not getting any audio from some mkv files with the following audio tracks:

ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : A_AAC-2
Duration : 45 min 32 s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 32.0 kHz
Frame rate : 31.250 FPS (1024 SPF)
Compression mode : Lossy

With or without passthru enabled.
Files play fine on computer.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I can’t see anything strange in that log. Does it play if you plug Vero into your TV direct?

Haven’t tried that but since there’s no audio when I disable passthru I’m doubtful. But I’ll give it a try and report back.

Disable passthrough on the Vero or the OPPO?

On the Vero. The Oppo feeds the amps via analog out.

Oddly enough I do get sound when from these files when plugged in direct to the TV - passthru enabled or not.
No sound from them when connected to the Oppo.

I guess you’ll have to dig through the Oppo manual then, or else use a fixed audio output samplerate and have Kodi re-sample everything.

If you just want to play the files without having to modify them or your setup you might have some luck setting your Kodi audio settings to 2.0 channels and in passthrough enable AC3 transcode.

That doesn’t work either.
Oddly enough I can use avidemux to copy the video and remux the audio to different formats and all play fine on the computer but still no audio with the Vero 4k+ connected to the Oppo 105.

Which formats? This seems to be an issue with 32ks/s. Are you changing the sample rate or just the format?

1 Like

I was changing the format and the bitrate. But changing the samplerate is what is needed, once I did that the remux worked.