No audio in InputStream decoded video after March update

Hi, after applying the March update I’m no longer hearing any sound in any of the widevine-encoded streams provided by the cpgo plugin.
This is on Vero 4K, with all the latest updates applied.
I didn’t change anything after updating, the sound works fine in all other media.
I tried to update/reinstall widevine manually from the inputstream helper plugin and it also didn’t help.
After examining the log, this line looked suspicious to me:

2020-03-28 10:14:41.022 T:3288421088 NOTICE: CVideoPlayerAudio::Process - stream stalled pts:123066694.680 clock:123066697.243

Everything I was able to find about it suggested that the cpu is not able to keep up, which doesn’t seem to be the case here, as the utilization during playback is consistently at about 30% on all cores.
Also, it worked fine just before the update.

The (slightly) edited log

I’d appreciate any help with this, thanks.

Have you tried another Widevine based add-on?

Unfortunately no, as I can’t find anything that wouldn’t require an account. I even tried to go over the list on inputstream’s wiki but it looks like most of the services are unavailable in my country.

I tried playing unencrypted streams from widevine’s integration suite and everything was ok.
In the unencrypted streams audio was also encoded in an aac stream, so probably not a codec problem.

I wasn’t able to test on the encrypted ones, as I’m not sure how license negotiation works and the docs seem to be available to licensees only. I guess that’s one more reason why drm sucks.
I also tried to run the same plugin on Leia on my laptop and it worked just fine.
Perhaps I’ll try to install osmc on rpi and see if it works there.


It seems to be a Polish add-on, so it was trickier for me to Google about the problem.
Can you contact the add-on maintainer and see if they are aware of an issue?


I don’t think it’s related to this specific plugin, as I was able to test it today, and it works well, without any audio issues on rpi 4, on latest raspbian.
I’ll try to test on osmc/rpi some time later this week.

Are you aware of any plugin that uses widevine encryption and doesn’t require a paid account?

Linux raspberrypi 4.19.97-v7l+ #1294 SMP Thu Jan 30 13:21:14 GMT 2020 armv7l GNU/Linux

Package: kodi
Filename: pool/main/k/kodi/kodi_18.6-1~buster_all.deb
Size: 22932952
SHA256: 89a7f6d37ead4836e1386855b83057ad98515b426de21259d02a01c004783b4e
SHA1: 77f53db1f14696e058f96bf549d48b60dac00dfb
MD5sum: 787e78b17dc1be94dbf5f18019a86b38
Maintainer: Diogo Santos <>
Source: kodi
Version: 2:18.6-1~buster