No audio on Dolby 5.1 video files

Following from a previous problem, I’ve upgraded my old optically connected sound bar with a new HDMI connected unit. It generally works well, except when I try to play a video file with Dolby 5.1 sound through the Vero. In that case, I get no sound. This did not happen with the old unit.

My system settings are as per the OSMC instructions. Other sound codecs work.

There’s a work around, though. Start the video, long press the menu button to bring up the audio display, and toggle the pass-through button off and on. Audio comes on when pass through is turned off, and stays on after a short pause when pass through is re-enabled.

I’ve up loaded logs.

I have two Veros. They both display this behavior, except that the other Vero produces noise before you do the pass through toggle trick. My second Vero has been connected to an HDMI sound bar for some time and I haven’t noticed the problem before, although it’s not used to play movies very much.

One other thing. The new sound bar reports ‘No Signal’ when the problem occurs. Video display is normal.

I’m traveling over Christmas / New Year (negative PCA test willing) so only have tomorrow (GMT +11) to play with the system if you come up with something. Otherwise, enjoy the festive system and we can take it up next year. Thanks for your support over 2021.


I believe you need to set the number of audio channels to 2.0

Thanks Tom.

@Tom_Doyle I don’t think so!

When using the HDMI output of your OSMC device for audio

Go to Settings/System/Audio… Select the following settings (keep in mind to set the settings level to ‘Expert’ in the bottom left corner of the settings window to see all settings necessary) :

  • Audio device:
    • Vero 2, 4K/4K +: PCM or HDMI
    • Vero 1: HDMI
    • Raspberry Pi: HDMI
  • Number of channels: 7.1 (so your AVR/soundbar/TV can do the processing of LPCM according to your speaker setup)

My sound bar is set up according to that document. It’s compatible with Dolby Atmos and DTS:X


Apologies completed missread your post (thought you were still using optical). Please can you try disabling Enable Dolby Digital (AC3) transcoding?

Thanks Tom.

It’s not enabled. I’ve set the audio channels to 7.1 as per the instructions and that option is not available.

I think the confusion here is that when you look at the logs it shows AC3 transcoding as being enabled but in reality the setting doesn’t actually get enabled unless you have your channels set to 2.0 (thus why it gets dimed in the UI for all other channel count settings).

As for the issue, not sure but I would enable Dolby Digital Plus in the passthrough settings and see if that makes the problem go away.


I’m away for two weeks so it will have wait until I get back.

I had the transcoding enabled for my old sound bar. Had I play with the settings before I left, and noticed if I reverted to 2.0 channels, transcoding was still selected. I deselected it, reverted back to 7.1 channels, but it didn’t fix the problem.

I’ll resurrect the issue when I get back. Thanks for the assistance so far.

Ignore this post, it’s incorrect. See below.

Well, I’m back from my holiday and spent some time playing around with the Vero audio settings to see if any affected the behaviour I’d observed regarding videos with Dolby 5.1 audio.

I’ve found the culprit setting.

When I replaced my old optically connected sound bar with a new one with an HDMI interface, I changed the Vero’s default audio interface setting, ie, the one that allows HDMI, optical and analogue connections, to HDMI only. (The first setting at the top of the audio configuration page.)

I’ve found that if I change this setting back to default, the problem goes away.

It seems that the HDMI only option affects playback of pass through Dolby 5.1 audio.

Is there an issue with the Vero software that deals with this option? I’ll leave that one to the experts.

Thanks for your assistance as always.

Please disregard the previous, it’s not correct. In my haste I didn’t realise I hadn’t re-enabled pass through, so it worked, but it’s not the issue. Apologies.

However, the issue seems to be the “Stereo Upmix” option. With that enabled, Dolby audio won’t play when set to pass through. With the Upmix option disabled, the video audio is as expected.

Again, apologies for the confusion.

The issue may be related to the sound bar. It’s an LG SPD 7Y, although logically the Vero wouldn’t be up-mixing 5.1 channels.

Any thoughts?