No audio on new Vero 4k

Hi There

Just received the Vero 4K, ran the update and lost all audio, any hints/tips would be much appreciated.


Firstly: you seem to be using sshfs and it’s mounted RO, so the databae updates are failing. You need to fix that first.

Can you describe your audio setup, as well as provide screenshots of how you’ve configured it?


I am using sshfs to mount a remote video repository, which is RO but it has no bearing on the overall issue as it won’t play audio from Youtube or any of the other plugins, not even GUI sounds.

Vero <–HDMI --> TV <-- HDMI --> AVR/HT

As per audio settings, right now they are on defaults, figured resetting to default may help but no cigar.

PS: thanks for quick reply.

You have a big database error in your logs (RO).
Needs resolving. Did you put ~/.kodi on SSHFS (only skimmed logs)?

HDMI should probably run from Vero 4K to AVR to TV ideally for the best sound. In this case you’d want to change audio to HDMI (default is PCM) and set # of channels accordingly and change to Fixed rather than optimised.


Ah yes I noticed that with VDB update, figured it was something to do with how I am trying to move my DB from the Zotac box to Vero but put it on the back burner to tshoot the audio issue.

I’ve lost the TV for the night (prime time for family) but will try rewiring first thing in the morning and update the thread.

PS: its weird though the sound worked initially and then stopped completely.

If it’s still borked, I’d try a fresh install (take a backup)
And start there.


So tried a few things, got frustrated and did format and started over. Sound worked again on 8.1, did an upgrade to latest available through My OSMC and sound still worked, then installed all adding and started the import of my sshfs repo and it still works.

At this point I am just glad everything works, would have been nice to know what went wrong but I can live with it :slight_smile:

Thanks again for your prompt support, it is much appreciated.