No audio when playing movie, can only hear GUI sounds in menus

Hi all,

I have a Sony HT-IS100 AVR, Panasonic Vierra TV and Rpi2 running the latest version of OSMC - all connected via HDMI; Rpi2 > AVR > TV.

The problem I am having is that when using the HDMI passthrough on the AVR, it allows me to see an image on the TV while the AVR unit is in “Active Standby”, oddly I can only hear the GUI sounds while navigating the menu through my TV speakers, as soon as I play a movie - I get no sound at all.

Removing the AVR from the setup, I get sound through my TV speakers when playing a movie. If I connect the AVR again, turn off the “Pass through audio” option in OSMC settings, I still only hear GUI sounds and nothing when I play a movie. I will add that everything works as it should when the unit is “fully on”.

Any thoughts on this would be greatly appreciated.

If you are using an avr, then you should want passthrough enabled.

The problem persists even with passthrough enabled. The AVR supports HDMI passthrough (Active Standby as Sony call it). In theory, I should be able to put the AVR in standby and I’ll still be able to get picture and sound to the TV - the picture works fine, the sound sort of works but only for the gui sounds. As soon as I play a movie no sound is heard through the TV. if I stop the movie, I can hear the GUI sounds again.

If the avr is in standby it will not decode passthrough streams but pass them directly to your tv. If the tv is unable to decode the bitstream (most tvs cannot handle dts for example) it will play the gui sounds that are just pcm but cannot decode the sound of the movie.

Try the ac3 transcoding option in the sound menu or let the pi decode the streams to multichannel pcm.

Edit: If you enabled the dsp plugin, disable that, too.

Thanks for the reply, I can’t seem to find the option to enable Multichannel PCM from the pi, or ac3 transcoding.

Is it the settings do to with the “Number of Channels”?

I think you have to enter expert mode (lower left side in settings menu) for those options to appear.

OK, so this is what I’ve tried:

Just enabled “Passthrough”, set “Number of Channels” to 5.1, cannot hear a movie encoded with DD5.1 (while the AVR is in standby), however I’ve tried a video that is encoded 2.0 and that works. If I turn the AVR on, the movie which is encoded with DD5.1 works as expected, the AVR displays “5.1 Ch PCM”.

I’ve then changes the “Number of Channels” to 2.0 and kept “Passthrough” on, this allows me to hear the movie with DD5.1 through my TV, which is exactly what I want. However, turn the AVR on and the movie with DD5.1 plays 2 channel.


If your receiver is able to decode ac3 (DolbyDigital) it should play the sound when passthrough is enabled.
Looks like your TV is able to decode AC3 but your receiver is not as it seems to revert to Multichannel PCM if it cannot decode the passed through bitstream.

What receiver do you have?

Edit: If passthrough is enabled and your receiver can decode the bitstream, the number of channels you selected in Kodi doesn’t matter.

Edit2: The receiver should be able to decode dts and AC3. So are you sure the file you are playing is dd or is it dd+ or trueHD as those formats cannot be decoded by your avr.
You can try to connect the pi directly to the tv and give the audio signal to the avr via optical or coax connection.

On your first edit; the odd thing though is that it does seem to matter. If I select 2.0 as number of channels, the AVR unit shows 2.0 Ch PCM, I’ve then used a Dolby Digital 5.1 test sound and it only plays through the front speakers. If I change the number of channels to 5.1, the AVR shows 5.1 Ch PCM and gives surround sound.

Again, if the AVR is in standby, set to 2.0 for “Number of channels” it plays through the TV fine, but no surround sound when the AVR is switched on. If I change it to 5.1 channels, I get surround sound when on, if I switch it off - no sound through the TV again.

PCM means that the signal is NOT passed through but decoded on the pi.

Hmm, I’m sure I’ve had passthrough disabled, then set it to 5.1 number of channels, but when in standby I still don’t hear anything from the TV speakers, only when it set to 2.0. If I have it set to 5.1, play it through the AVR, I get surround sound. If I have it set to 2.0 with it still switched on, I only get sound through the front speakers of the AVR.

As you do not want to answer my questions:
Sorry, I cannot help you…

What question?

To be honest, I’ve tried every combination possible to try and get it to work, with no luck. I don’t have the hardware to try optical or digital coax on the rpi, HDMI is my only option.

Ok, so can you give us some information about the file you want to play? With mediainfo or something? Is the problem present with all 5.1 files?
Have a look around your avr’s menu, if there are some decoding options that are disabled.
Also check if “dts capable receiver” and “ac3 capable receiver” is checked in audio options.

Yes, all dd5. 1 and DTS movies have the same behavior as explained above. Only videos with 2.0 channel plays through the TV speaking when the AVR is in standby.

I’ve downloaded a DD5.1 test video (a VOB file), which tests each channel separately, again, exactly the same behavior as explained in previous posts.

I think I might have to admit defeat with this…

Also, forgot to add, I’ve checked the settings on the AVR and there is nothing I can see which would cause this behavior.

The HDMI control option on the AVR (which allows passthrough) can only be set to on/off.

If it’s on, I can get a picture to the TV while in standby, and obviously nothing if it’s set to off.

Are the two options I mentioned in my last post activated?

Yes, both active as they work if the AVR is turned on.

Surely you must be able to watch, and most importantly listen to a movie if the AVR is in its active standby mode, regardless of how the movie is encoded.

If the AVR says it is multichannel PCM, it is NO passthrough!!!
Sorry, you do not really read my replies and repeat the same things over and over.
So just do whatever you want.

It’s not that I’m not listening. I think you’re missing the point. If I disable passthrough, it is decoded by the rpi - therefore my AVR says either 2.0 or 5.1 ch PCM, as you’d expect. If I turn on passthrough, the AVR says either Dolby Digital or DTS on the display. But regardless, if the unit is in active standby, it does not allow me to hear audio through my TV speakers unless it’s something encoded with 2.0!

That is the issue, and that what I don’t understand.