No Audio with DTS-HD-HRA Movies

I thought you would make a test build based on the HRA patch posted in my topic?

I’m not going to have the time this weekend to test anything but thanks for the offer, I think I shall leave the status quo as is for the time being.

If you enable DTS passthrough but disable DTS-HD, I think vero will send the core 5.1 to the receiver. If you disable passthrough entirely, vero will decode the HRA which ought to sound better than the core 5.1. Only your ears can tell.

Which one was that? If you mean the link to the LAVfilters thing we’ve looked at that but are struggling to reproduce that with kodi.

Yup that one, been waiting for a test build since Sam said that would be coming shortly, haven’t heard anything since that post though.

There’s been progress but still working on exactly what to feed to the hdmi driver.

Let’s discuss where we got to on Slack; as I’m not able to remember fully.

I’m not sure if such high level information helps but I’m running an RPi3 and a Vero 4K in parallel both running on the latest June OSMC software. Kodi audio settings for both devices are the same and both are connected to the same AV receiver.

The Raspberry plays HRA files without any issues while there is no sound with the Vero when Audio Passthrough is activated.

The only difference in the setup I can think about as such is that the Vero is connected through a HDCP 2.2 HDMI connector.

RPi will not pass through hi-res audio. I assume your AVR is displaying PCM, same as it will if you turn off DTS-HD passthrough on the vero.

What make/model of AVR, BTW?

Indeed. The plan is to add an option so that passthrough is used for all formats but add an option so that HRA can be passed as PCM in the same way it would be on a Pi. This should be a sufficient workaround for problematic receivers.

Sam

Thanks for the quick responses!

Disabling “DTS-HD Passthrough” on the Vero is my current workaround.
Could you explain the difference to the workaround you are looking into?

AVR is an Onkyo TX-NR646 and according to the specs it supports DTS-HD High Resolution Audio. It displays “dts” in all three cases:

  • RPi3 => DTS-HD-HRA sound plays on the AVR
  • Vero (DTS-HD passthrough disabled) => DTS-HD-HRA sound plays on the AVR
  • Vero (DTS-HD passthrough enabled) => no sound

/Michael

DTS-HD includes HRA, MA and DTS:X. DTS-MA is working with your AVR. So what we are looking at is to disable just HRA and not MA.

On the Pi, it will not be playing DTS-HRA but just the DTS ‘core’ which is compressed 5.1.
Same thing with vero and DTS-HD passthrough disabled.
With DTS-HD passthrough enabled it won’t play HRA but should play MA and possibly DTS:X.

The problem is in the Cirrus logic chip which your Onkyo and some Denons use.

Many thanks for the clarification and education! :slight_smile:

1 Like

I spoke to Anthem support, who make popular premium AV receivers. After providing them with technical details, they have unfortunately announced that there is not enough demand in DTS-HD HRA for it to be explored further.

I have a workaround that will provide the same quality of audio, however it will be streamed as PCM.

Unfortunately I can’t go in to full details. If a company that manufacture $8000 receivers are not interested, then Denon won’t likely care about receivers that are a tenth of the price.

We will continue the development on our own.

Sam

This makes sense…the number of commercial releases with HRA is likely less than 1000, out of literally hundreds of thousands of disk titles worldwide. For people who re-encode, though, HRA is great at keeping very high quality while saving a lot of space compared to DTS-HD MA tracks. You can save around 1GB per movie by converting to HRA.

HRA seems to be common with German BD releases, so it’s not a market to be neglected.

Especially with newer HRA based DTS:X titles which can’t be converted or they loose the 3D information… So, the number of HRA disc titles is continuously growing and will probably do so with more and more DTS:X tracks being released.

29 posts were split to a new topic: 24-bit output

We’ve had some users report this issue resolved with a test build prior to this update. The July update incorporates these changes to audio and will therefore hopefully solve the DTS-HD HRA issue for you as well. :slightly_smiling_face:

If there’s nothing to add from your side, I’ll close this thread in three days.

1 Like

This topic was automatically closed after 3 days. New replies are no longer allowed.