No Audio with DTS-HD-HRA Movies


Is it possible that the new update screwed up something with the DTS-HD-HRA Audio?

I don’t get sound from any movie with this audio format. Normal DTS, DTS-HD-MA, True Hd, Atmos etc… works fine, only the HRA DTS Tracks not.

I bought a new AVR (Denon AVR-X1400H) so i am not sure if this is a problem with the Vero/Osmc or with the AVR.

Can somebody check this please?


Using passthrough?

yes of course, all other formats are working fine, also DTS-HD-MA and Dolby Atmos

Maybe this will help:

Kodi Log:

Movie with DTS-HD-HRA:

I may be missing something but I don’t see DTS-HD or DTS-HD-HRA in the Denon specs - only DTS-HD-MA

1 Like

DTS-HD is the Core so if the decoder can DTS-HD-MA, it also can DTS-HD-HRA

Atmos also is only in the TrueHD core Steam and is not an seperate

To my knowledge DTS-HRA is a given, if DTS-HD MA is supported…

Right. And in Kodi you can only enable DTS-HD so all HD is included there i can’t enable DTS-HD-MA or HRA

I can’t see anything wrong in the logs. OSMC is just sending a raw signal through as expected. Does the movie play on other hardware?

So, did some digging into the manuals of @Painkiller88’s Denon AVR-X1400H and my Denon AVR-X4300H…

This is the page from the 1400’s manual listing all supported sound formats:

And this from my 4300’s manual:

So, Denon doesn’t list the formats under the specifications section of the respective AVR’s website (rather just calling them DTS-HD and Dolby Surround). But here, DTS-HD HI RES (what Denon calls it - it’s the same as DTS-HD HRA, I guess) is clearly supported by both models… :slight_smile:

1 Like

Just looking on another thread, Sam recommends audio settings at 7.1 and Fixed when using passthrough.

Just did a short test with this test file: DTS-HD HRA test file

Here it’s working like a charm! Sound is working and my AVR is showing DTS-HD HI RES. :thinking:
BTW: Using 7.1 setting with best match. :wink:

1 Like

Like @Chillbo said: No issue with DTS-HD HRA using 7.1, best match, pass-through and here a Sony STR-DN840. It’s displayed as DTS-HD HRA in my AVR’s display.

@Painkiller88 From your logs: … mkvmerge v5.8.0 … dated 2012
Could you try remux one of the problem video with actual MKVToolnix at ?

I’ve got the Denon AVR 2400H. DTS HRA is working fine here.

yes i can try but this movies all run before so if the played once i think the should do it every time

I was able to figure out, this is not an issue of the Denon AVR

I took one of my original discs with the DTS-HD-HRA Audio format and put it into my PS4, here all is working fine.

So it’s a issue with Kodi.


Maybe you can have a look on it, would be great.


Isn’t this probably the same issue as here: Issue with DTS-HD and Vero 4k

Also Denon and some weird format playback issues with Vero 4k…

I have just played my first .mkv with DTS-HD HRA and found the audio to be very low and when I increased it a lot, what audio there was sounded distorted. Setting the Vero 4K Audio setting to Fixed, fixed it.

Thanks to grahamh & Wuschel_Wuschel for their comments & link to the thread of “Issue with DTS-HD and Vero4K”

Just updated to the jannuary update of osmc on vero4k.

no improvements for DTS-HRA. Still no sound on that files

As far as I know, there weren’t any improvements for this in the January update. The same for Denon and Atmos passthrough issues.