Issue with DTS-HD and Vero4K

Hi,

Yesterday I replaced my AV receiver with a new one supporting HDMI 2a and HD audio.
So connection now is Vero4K -(HDMI)-> AV receiver -(HDMI)-> 4K HDR TV
Everything works OK, except one:
No DTS-HD sound!
All other formats are playing fine, including Dolby HD.
Debug log is http://paste.osmc.io/wisecaxojo.vhdl

Also
cat /sys/class/amhdmitx/amhdmitx0/aud_cap

CodingType MaxChannels SamplingFreq SampleSize
PCM, 8 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16/20/24 bit
DTS, 6 ch, 44.1/48/88.2/96 kHz, bit
AC-3, 6 ch, 32/44.1/48 kHz, bit
DTS-HD, 8 ch, 44.1/48/88.2/96/176.4/192 kHz, 16 bit
Dobly_Digital+, 8 ch, 44.1/48 kHz, bit
MAT, 8 ch, 44.1/48/88.2/96/176.4/192 kHz, bit

Note: sometimes during playback, if I hit pause and then play (2 – 3 times) that might enable the sound.
The vast majority of my collection is DTS-HD based so it is important for me to solve it.

Can you post a screenshot of audio settings?

sure

Change from best match to fixed
Make sure sync playback to display is disabled.

Do you have another system to briefly test on? One guy had a similar issue (EDID) related. We worked around it by tricking Vero 4K to send the signal anyway.

FIXED will disable pass-through so not an option.
EDID problem seems possible.
Sometimes DTS-HD is working but it’s random behavior

I have another system, but it is windows based

what’s the trick you mentioned?

Fixed does not disable passthrough.
Have you tried this?

Yes, twice
when fixed is selected, then the passthrough option is totally disabled at the gui
and, i don’t get either dts or dolby at the receiver.
I am sure that other people in this forum also stated the same for the fixed setting …

Tried fixed with 2.0 channels? And 48k?

2 Likes

I’ll check the debug log in a bit. Should be clear why passthrough isn’t being used.

I assume that when passthrough doesn’t work you see 7.1 PCM on the amp?

Sam

The log shows passthrough isn’t being used; but the stream is correctly detected as DTS HD.

I think it’s a timing issue with your amp. See Sometimes no sound on play - #35 by sam_nazarko. This may help. It effectively lets you override audio capability settings. Provided you’re not moving between setups frequently, you shouldn’t notice problems with this approach

Sam

OK thanks for suggestion, I’ll try this “hack” later today, and report back.
BTW is there any possibility that the next update will include a fix for this issue?
One more thing

it does disable it in my case! Any idea why?

Without a log for that, not sure.

I suspect when refresh rate changes, it takes too long for your AV and TV to renegotiate.
Disabling Adjust Refresh Rate temporarily might improve the success rate of passthrough being chosen and confirm this suspicion.

But if this is the case why the issue appears only when sound is DTS-HD?
In all others sound formats there is no issue, including Dolby-HD

Off the top of my head, no definitive answer. But it’s worth a shot when you get a chance.

Did it all work fine with your older receiver?

In my previous setup Vero4K was connected directly to TV, and from TV an optical cable --> to receiver.
So we cannot compare the two setups.

Indeed. That’s also why we don’t check caps for passthrough on some codecs as it’s impossible to determine.

When you can let me know how the workaround goes and whether the Refresh Rate change helps

@LED123 May ask what brand and model is your new AVR? (I find so many issues with Denon and DTS-HD with google, astonishing)

Unfortunately neither the workaround nor the Refresh Rate Change helped.
Same behavior.
Don’t know what else to do, the new AVR is almost useless this way…

It’s a Denon AVR-X540BT
it’s a 2017 model
Could you please share a url where you found reports of issue with Denon and DTS-HD?

I simply googled for “denon dts-hd problem”. Here in this forum there is another thread with DTS-HD issues and a Denon AVR: No Audio with DTS-HD-HRA Movies
Might be the Denon’s share in the market is that high but for me this is eye-catching.