No automount after editing the fstab

Hi guys,

I am followed the HOW-TO but it is not working for me.

osmc@osmc:~$ sudo mount -t cifs -o username=kodi,iocharset=utf8,vers=3.0 //192.1 68.1.4/video/Filme/HD /mnt/HD
Password for kodi@//192.168.1.4/video/Filme/HD: ********
osmc@osmc:~$ ls -la /mnt/HD
-rwxr-xr-x 1 root root 17271090935 May 19 23:20 Name des Films.mkv

Entry in the /etc/fstab:
//192.168.1.4/video/Filme/HD /mnt/HD cifs x-systemd.automount,noauto,rw,iocharset=utf8,credentials=/home/osmc/.credentials,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,ver=3.0 0 0

I have also tried the following parameters:
nounix
sec=ntlm

with the kodi internal smb client it is working.

command: smbclient -m smb3 -U kodi -L 192.168.1.4
response:
Domain=[SYNOSTATION] OS= Server=

    Sharename       Type      Comment
    ---------       ----      -------
    homes           Disk      user home
    music           Disk      System default shared folder
    photo           Disk      System default shared folder
    Software        Disk
    video           Disk      System default shared folder
    web             Disk      System default shared folder
    IPC$            IPC       IPC Service ()
    home            Disk      Home directory of kodi

Domain=[SYNOSTATION] OS= Server=

    Server               Comment
    ---------            -------

    Workgroup            Master
    ---------            -------

Hi,

What isn’t working?

with these flags x-systemd.automount,noauto its expected the share won’t automount on startup, only mounts them when you access or the share (or library scan). So are are you not able to access the shares?

Thanks Tom.

@Tom_Doyle
Thanks for the response.

Yes, I am not able to access to the shares.

osmc@osmc:~$ ls -la /mnt/HD
ls: cannot open directory ‘/mnt/HD’: No such device

Hi,

is that typo on discourse or fstab, shouldn’t it be vers=3.0?

If that isn’t it, whats the output of:

sudo mount /mnt/HD

Thanks Tom.

P.S I edited your post, to make the fstab entry easier to read.

1 Like

Hey @Tom_Doyle,
many thanks for our help.

I didn’t put the “s” in it, so it didn’t work.

Now it is working perfectly.

1 Like

/etc/fstab entry:

//192.168.80.4/video/ /mnt/video cifs x-systemd.automount,noauto,rw,iocharset=utf8,credentials=/home/osmc/.credentials,uid=osmc,gid=osmc,vers=3.0 0 0

I am searched already in the forum for my issue and found only the following thread, but this not resolved my issue:

After every reboot the mountpoint is missing.

osmc@osmc:~$ ls -la /mnt/video/Filme
ls: cannot access ‘/mnt/video/Filme’: No such file or directory

Run the command without an output or error: sudo mount /mnt/video

The access is now possible:

osmc@osmc:~$ ls -la /mnt/video/Filme
total 0
drwxr-xr-x 2 osmc osmc 0 Aug 16 2019 .
drwxr-xr-x 2 osmc osmc 0 Mar 12 19:56 …
drwxr-xr-x 2 osmc osmc 0 Jun 21 03:43 HD
drwxr-xr-x 2 osmc osmc 0 Jul 3 12:49 UHD

I am have the latest osmc update and the latest DSM update from my synology NAS. I am use SMB3.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

here is the log file: https://paste.osmc.tv/axowakofos

Steps to reproduce:

  1. activate the logging and reboot the device 2 times
  2. open a video file like 3 days to kill and the first episode from bates motel
  3. file is not available message is shown
  4. run the command via ssh: sudo mount /mnt/video
  5. open the same file again and the movie is playing now
  6. reboot the device and i need the steps/command again

I don’t found an issue in my fstab.
I tried SMB3 and SMB2, but neither worked.

Hi,

Have you got wait for network enabled in network settings in MyOSMC?

Looks like a library scan is trying to mount the share, before the network is up.

Thanks Tom.