No bluetooth or wireless

I have no Bluetooth or Wireless options under My OSMC > Network. I have been using my wireless adapter just fine in the past. Same for my Bluetooth keyboard. Looks like an update broke something. I don’t even know which one, as I don’t use my Bluetooth keyboard very often. I went and checked for updates manually, as it was suggested by someone. It found additional updates and installed them, but wireless and Bluetooth options still didn’t show back up. I can see Bluetooth flash in the list next to Wired, but then screen refreshes and option disappears. I took a short video even.

  • Need logs
  • Need to know which device you are using
  • Need to know which WiFi adapter and Bluetooth dongle you were using

Sam

Raspberry Pi 2 Model B
Kinivo Btd-400 Bluetooth 4.0 USB Adapter
Edimax EW-7811Un 150Mbps 11n Wi-Fi USB Adapter

Not sure how to get the logs, your wiki link doesn’t work
https://osmc.tv/help/wiki/system-log1.8k

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thank you

http://paste.osmc.io/etimilusut.vhdl

I believe you should check your powersupply, cable and potential USB hub if you use that.
[ 7.152361] usb 1-1-port2: over-current change
[ 7.409409] usb 1-1-port2: over-current change
[ 7.663698] usb 1-1-port2: over-current change

Try adding max_usb_current=1 to config.txt or using a powered USB hub. It might also be that you have damaged your USB power regulator

Also provide lsusb output by lsusb | paste-log (lsusb you might first have to install via sudo apt-get install usbutils)

Here is paste log
http://paste.osmc.io/uvayuyuxiq

Did you add the max usb setting? Are you using powered usb hub?
lsusb is not detecting anything other than the internal devices which either means nothing powering up or you damaged the usb power regulator

Hi, I added max_usb_current=1 to config.txt that I found in the root of my SD card, but that didn’t help.

I’m not using a powered hub. I dont have one

How could usb power regulator be damaged? My Pi is just sitting next to TV, noone is touching it or messing with it via SSH.

This is the power adapter I have. http://www.amazon.com/gp/product/B00MARDJZ4
Would you say it’s not enough?

It’s always hard to judge from just the printed information as you never know if powersupply and cable also deliver a constant voltage to the Pi.
Anyhow I don’t think that you powersupply is the culprit as mentioned I believe something else wrong with the PI.
Maybe first try only one of the two devices and check if it shows up in lsusb. If even a single device doesn’t show up my guess it that the USB power regulator is blown.

Doesn’t show up even if only one dongle is plugged in. How would USB regulator get blown? Does it mean I got a defective rpi?

To confirm, install a fresh Raspbian install and see if the dongles are recognized.

Many possibility, e.g. read [Solved] USB not working - Raspberry pi 2 - Raspberry Pi Forums

I doubt so as you in your initial thread wrote it worked before, didn’t it?

Thanks for the link.

I still may have a defective rpi, that took a few months to break. Don’t you think that statement makes sense? That’s what I meant by ‘defective’ even though it worked before. Now that I have this spelled out for you, I think we’re on the same page.