No "Bluetooth" setting in audio output options

Hey everybody,

I am using a Raspberry Pi 3 running the latest OSMC (last updated 2017-07-24) as a media center an in general anything works just fine and i love it.

Now, I want that media center to be somehow “portable” when only playing audio which means I want to connect a Bluetooth Speaker (specifically: UE BOOM) to the Pi’s very own Bluetooth device and use it as audio sink while the Pi/OSMC itself is the audio source.

I can connect the speaker in most of the cases either using myOSMC of via ssh (bluetoothctl) but it seems like I can’t set the Pi’s Blutetooth device as audio sink.
The only options I have in OSMC’s audio settings are:
PI: Analogue
PI: HDMI and Analogue
ALSA: Playback/recording through the PulseAudio sound server
ALSA: PulseAudio Sound Server

I tried to set every single option as audio output while playing music with OSMC having the speaker connected but none of the seem to work.
To me it feels like I am missing the right audio output option. Is that possible?

I also tried a lot of different manuals that I found using google search which I thought could be solutions but none of them did the trick.

Can someone give me a hint?

Thanks in advance…

Well my hint is use search function (top right) before posting :wink:

To use Bluetooth audio you need to install bluetooth A2DP test package see this thread

1 Like

Thanks for the quick reply and the wake up call @fzinken :slight_smile:

I already found that thread but obviously misinterpreted it. I thought it was only about streaming audio from a device (e.g. cellphone) to the Pi… My bad.

I’ll give that a try.

True the headline can confuse. But that package is needed for any bluetooth audio function.

Installation was successful an now I have the options
PI: Analogue
PI: HDMI and Analogue
ALSA: OSMC streaming to Bluetooth speaker / headphones

I haven’t had the time to extensively test it yet, but I think this thread can be seen als solved (as I now have the option that I was looking for in the audio settings menu) :slight_smile:

thanks again @fzinken

I am sorry to reply to an old thread (that again references an even older thread)

But I can’t find a newer or more recent thread.

I have done everything in this thread, included making sure to be up to date with the latest updates, followed the link “[TESTING] Bluetooth audio streaming (A2DP)” and ran the commands and installed the

and now I have even received the official OSMC bluetooth dongel. Finally I can connect to my bluetooth headset, when I restart the Pi, but when I am playing it only outputs through HDMI, even when I go OSMC’s audio settings I only have the 4 settings…

PI: Analogue
PI: HDMI and Analogue
ALSA: Playback/recording through the PulseAudio sound server

I am currently trying on the ALSA one, but it is still outputting audio to HDMI,

I cant seem to get the “ALSA: OSMC streaming to Bluetooth speaker / headphones” settings to appear.

Any help would be greatly appreciated.

Basically you choose “ALSA: Playback/recording through the PulseAudio sound server” and PulseAudio will sent to HDMI or Bluetooth if Bluetooth speaker is connected.

Suggest to check via bluetoothctl that headset is connected properly and with the right profile.

1 Like