No boot / nothing happens

I plugged my Vero4K+ after 3 months “off”, and nothing happens… No red light on the box, nothing on the screen.

I tried powering it through USB ports, without any success (with a powerful usb adapter…)

What can I try ?

Thank you very much !

If you haven’t used it for a few months, I assume it’s been in storage.

Are you sure you are using the correct power supply?

the one I use is supposed to deliver 5V 2A DC. (“model TSL_1681”)
(it was next to it in the storage box !)

I seem to recall you having some booting issues before.

Have you tried a cable in the white USB port to see if it’s detected by your PC?

Hello !
New tries this morning : it boots powered up through USB.

I previously used a USB C <-> USB A connector (USB-C connected to a powerful enough charger, USB A in the white USB port of the Vero,), but it does’nt work with this cable.
Using a USB A - USB A cable I previously built for debuging works !

So I guess it’s the power plug which fails ! (ouf, not the Vero itself !)

USB-C to A adapters won’t work as expected.

You can grab them here;