No browsing of NFS shares with Synology

If you’re mounting via fstab, why are you browsing for NFS?

Should show a (local) path because mount is handled by fstab.

Hi Chris,

When you set the file permissions to everybody, other than ro, or rw, what other settings did you have. From looking at kodi wiki link you provided, it would be something like this:


@sam_nazarko I don’t think Chris is mounting via fstab.

Thanks Tom.

Hi Tom,

other settings are/were: rw for admin and my user; local permissions (that’s the term the guy in your link was referring to): administrator rw, users ro.

I just tried the line you’ve posted, still the same.

@sam_nazarko Tom is right, I’m not mounting via fstab.


Have you tried adding the NFS share to sources.xml or directly, instead of browsing? Browsing won’t always work properly. You could just copy sources from your old Pi 2 if used there.


FYI, I made a blooper with the no_acl option (and typed no-acl). I’ll amend the earlier post accordingly.

Hi Chris,

I think it may be worth trying a kernel mount, as this may give us more an idea of whats going on:

Thats just an overview, you will need to access to the command line to do this:

sudo mkdir /mnt/volume1

the default password is osmc

sudo mount /mnt/volume1

If there is an error please advise what it is, no error:


and advise on the output.

Thanks Tom.

I just copied the sources.xml to the Vero and it’s working. Actually it’s not solving the problem in my original post, but I’m happy. Thanks, Sam.

Hi Tom,

mounting gives me the following error:

osmc@osmc-Ian:/mnt$ sudo mount /mnt/volume1
mount.nfs: access denied by server while mounting

But I did this after I added the sources.xml, not sure, if this is an issue.


Hi Chris,

If copying sources.xml to the vero has now now let you browse the shares, what I suggested is no longer required; I wouldn’t worry about the error. I hadn’t thought of trying Sam’s solution.

Thanks Tom.

Care to share:

  1. your /etc/exports that worked
  2. the relevant part of sources.xml

for future generations?

Tom’s command was slightly wrong. It should have read:

sudo mount /mnt/volume1

since you were exporting /volume1/video, not /volume1

don’t know how I missed /video apologies.

Just for the record, and for future reference, I read up on the Kodi site about using NFS on Kodi becasue it might always have its own little wrinkles. Here’s what it says about sharing NFS from Linux:

A basic configuration for exporting a path with NFS looks like this:

/nfs/export <ip or iprange which is allowed to connect>(rw,all_squash,insecure)

The important options here for use with Kodi are the “ip or iprange” and the “insecure” options. The “insecure” option is needed because we want to be able to run Kodi without root privileges. If the insecure option is not enabled, only the root user (uid 0) will have access to the nfs share. The “ip or iprange” specifies which hosts on the network will be allowed to access the exported NFS share.

And here’s what the Debian (and Fedora) man page says about the insecure option:

secure This option requires that requests originate on an Internet port less than IPPORT_RESERVED (1024). This option is on by default. To turn it off, specify insecure.

So, AFAICT, the insecure option has absolutely nothing to do with allowing non-root access and everything to do with allowing access to a port number >=1024. The Kodi documentation seems to be wrong - but everyone on the Kodi forum was religiously following this instruction. Its effect is fortunately benign but it’s still wrong.

Here is what i did to get it working on a Synology DS716+II (8GB) DSM 6.1.1-15101 Update 2, with both Vero 4K and Raspberry Pi 3.

First enable NFS and assign NFS permissions according to this link

After that you have to change permissions for the folder via File Station.

Open File Station, right click on the folder you want to use as NFS share and choose properties.
Select the Permission tab, and click create > and select Everyone from the list in User or Group, and check what what permissions you want, I choose Read and Write.

The second part was not necessary on earlier Versions of the DSM, but it has to be done now, even though it might be a security risk.

Thats all you have to do to get NFS working, I did not edit any files,.

Hope this helps.


It’s work’ for me in the same way.

Details please, guys @thansen_dk @michael47. Which DSM versions are you talking about? Such information is important.

I’ve negotiated access to a Synology box but it’s stuck on DSM 5.1 and the latest version is now 6.1. So it’ll be important to see if there are any significant differences between the two versions WRT NFS.

I started with Vero 2 and Synology 5.1 , when I remember right basicly the same way.
And I’ve spend time to search on OSMC, Kodi, and Google to play with and found the solution for my case.
Now I’m with Vero4 and DSM 6.1.
For first debugging I think

  • try first to see the NAS in the KODI nfs share, when not, you have a NAS configuration problem = check the link from Thomas.

I don’t touch my NAS (production and backup) to try to make a new How-To, but if somebody with a fresh install try to write it, I’m happy to help (in my free time)

For Synology User
Synology work’s a lot for new security features.
I’ve disabled the auto update feature in Synology. I only look mnually for updates for the same DSM Version, and take a look to the changelog…
And take care with major updates (with number changes like 6.0 - 6.1) Wait a little bit,and take a look to the different forums of you third partys appliactions, like DVBLink or others.

Synology DS716+II (8GB) DSM 6.1.1-15101 Update 2

I have edited my original post, with the details :wink:


I couldn’t answer yesterday, I was out of replies :smiley:

So here is my /etc/exports:

/volume1/video *(ro,async,no_wdelay,crossmnt,insecure,all_squash,sec=sys,anonuid=1024,anongid=100)
/volume1/music *(ro,async,no_wdelay,crossmnt,insecure,all_squash,sec=sys,anonuid=1024,anongid=100)

and the sources.xml:

        <default pathversion="1"></default>
        <default pathversion="1"></default>
            <path pathversion="1">nfs://</path>
            <path pathversion="1">nfs://</path>
        <default pathversion="1"></default>
            <path pathversion="1">nfs://</path>

Something else: I only concentrated on the video section and I had problems problems with adding the music folder. The permissions had to be set like in the link Tom mentioned: Solved - Synology NFS shares not working on Android or Windows (does work on Openelec) - Printable Version
Otherwise it didn’t work.

I’m also using DSM 6.1.1-15101 Update 2, my Diskstation is a DS415+.

Thank you all so much. Have a great weekend.


Brilliant. Glad this is resolved!

1 Like

Thanks for the feedback guys. It’s good to have a record of what actually worked.

I’ve just had a play with my friend’s DS210j, which is pretty ancient and runs DSM 5.2 but seemed to work just fine on the tests that I threw at it. I’ll write up my findings in a day or two.

Correction: It was DSM 5.2, not 5.1

Edit 2: Write-up is here.

1 Like