No display on projector, okay on monitor - Vero 4K+

Just received new Vero 4K+.

Setup fine on my computer monitor (though updates failed first time OSMC Update Error - Vero 4K+)

But when connected to projector (directly or through receiver), there was no display. It does display when booting, but not once OSMC has fully booted. Video: https://1drv.ms/v/s!ApUGoav2wlgmid8BL92wMhRVqIfSWg

Projector does display 1920x1080p fine from Windows PC and two KODI boxes. (And indicates “1080p” while Vero is booting, see video linked above.)

Took Vero 4K+ back to monitor and tried setting different refresh rates: 60 (default), 59, 50. None of them work on projector once OSMC has fully booted.

Looked through all video settings in Advanced mode and don’t see anything else to try…please help!

Tried two different HDMI cables - both work fine on monitor, neither on projector.

Is the 4K directly connected to the projector, or to a AVR? If it is on an AVR try directly connecting it. Otherwise, please supply logs.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks grahamh. I was hoping someone might have some quick answers if they’d seen this before. Here are the remaining Qs from that link:

  • Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue.
    Yes / Only occurs with my projector, but the projector does display 1920x1080p fine from Windows PC and two older KODI boxes.
  • The device you are currently running OSMC on
    Vero 4K+
  • What peripherals are attached to the device?
    Denon AVR & Infocus X10 projector
  • Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?
    No, new unit.

To answer bmillham’s question above, I did try the 4K+ directly connected to the projector, same issue.

It displays fine during first part of boot (projector indicates 720p) and the second part of boot (projector indicates 1080p). But once, fully booted, there is no display.

Logs: paste.osmc.tv/umeyomuwik

After turning on logging, the 4K+ was connected to the AVR/projector and booted at 20:02 ET, however, because it didn’t display after fully booting, I had to unplug it and take it to my monitor upstairs to upload logs.

I don’t actually see the boot time at the projector in the logs…is it possible the logs don’t get recorded if the power gets pulled?

I’m hoping you can see something here. Otherwise I will have to lug my huge monitor to the room where the projector is installed so I can switch cables on the 4K+ and upload logs without losing power.

I suggest you access your Vero via SSH while you are not having a picture and upload logs via grab-logs -A because only then we can see what modes are received in that moment.

In the current log we only see the values from your Benq Monitor which doesn’t help much.

Thank you fzinken, I should have thought of SSH.

Logs grabbed while connected to the projector: https://paste.osmc.tv/yidorefose

The log shows the following video modes are supported:

480p60hz
576p50hz
720p60hz
1080i60hz
1080p60hz*
720p50hz
1080i50hz
1080p30hz
1080p50hz
1080p25hz
1080p24hz

The asterisk indicates that the preferred mode is 1080p60hz.

Is the GUI set to 1080p?

Sam

Please try this:

echo 8bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

If that works, try setting the output to 422 in Settings->System->Display. If that survives a re-boot you should be good.

Thanks for checking that in the logs. Yes. (Reported in the OP: I tried setting different refresh rates: 60 (default), 59.94, 50. They worked during boot, but not once the GUI had booted.)

Thank you!! That worked.

GUI now displays on Projector through AVR. Thanks. Presume lower quality due to reduced color space, but that’s all my projector supports. What command should I enter to undo if I replace the projector in future?

New logs: https://paste.osmc.tv/wotayosiya

Since nearly all source material is distributed as 4:2:0, there should be negligible difference between that converted to 4:4:4 and to 4:2:2.

Just unset the 422 setting. The ‘8bitnow’ doesn’t survive a re-boot.

For the record, the problem is Infocus have not understood the HDMI specification. They are advertising ‘deep color’ but the projector does not actually support it.

Thanks for the additional detail.

Great support!