I don’t know how long I have had this problem - maybe since last update?

Connection is via WiFi. The DHCP server is configured to provision nameservers - nothing changed there, all other devices work fine.

The problem is that no DNS names resolve:

root@osmc:~# curl
curl: (6) Could not resolve host:

/etc/resolv.conf contains:

nameserver ::1

Tried reboot … don’t really know how OSMC handles networking, so don’t know where to start looking.

OSMC uses connman network manager. The only idea I have is that you managed to manually configure a (wrong) nameserver although using dhcp.

Look at the file /var/lib/connman/wifi*/settings and verify whether there is a nameserver configured. If you see a line starting with Nameservers, this could be the issue since it only occurs if you have once manually overwritten the nameserver information provided by dhcp, I think.

A solution could be to remove the actual config:

  • kill all wifi settings from the command line and reboot:
    sudo rm -R /var/lib/connman/wifi* && sudo sync && sudo reboot
  • in the main -> settings -> my osmc -> network -> wireless menu select your ssid and connect again using the right passphrase (I know it’s tedious to enter this with the remote control)
  • to be sure select wait for network in the wireless menu and reboot the RPi

Reboot your router/modem/AP as well.

1 Like

Found it … it was my VPN.