No DTS nor DD on passthrough configuration (altough 2 channel audio seems fine)


#1

So, I have a raspberry pi 3B+ with a hifiberry digi+.

I have connected the S/PDIF output to my receiver (DTS and DD capable).

The OSMC automatically detected the hifiberry and I was able to select it as audio output in the configuration. I enabled the passthrough options as I want my receiver to do the work.

Audio is reaching my receiver as I have 2 channel sound from the S/PDIF output on the receiver. The problem is, i have no DTS nor DD audio. Neither DD nor DTS videos are in 5.1 channels. The video files reports the 6 channels correctly, but only stereo get’s to the receiver. Kodi logs:

14:31:39.065 T:1885336320 DEBUG: CActiveAESink::OpenSink - ALSA Initialized:
14:31:39.065 T:1885336320 DEBUG: Output Device : snd_rpi_hifiberry_digi
14:31:39.065 T:1885336320 DEBUG: Sample Rate : 44100
14:31:39.065 T:1885336320 DEBUG: Sample Format : AE_FMT_S24NE4
14:31:39.065 T:1885336320 DEBUG: Channel Count : 2
14:31:39.065 T:1885336320 DEBUG: Channel Layout: FL,FR
14:31:39.065 T:1885336320 DEBUG: Frames : 2205
14:31:39.066 T:1885336320 DEBUG: Frame Size : 8

ALSA it’s only reporting 2 channels. ¿Can this be an ALSA issue?

In Kodi there is no option to select the number of channels.

¿Any help?

¡¡Thanks in advance!!


#2

Hi,

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Tom.


#3

Sure, here are the logs:

https://paste.osmc.tv/uzubalelig

and here is the mediainfo data:

http://paste.osmc.io/ayovidihif.sm

Regards.


#4

Hi,

Try disabling sync playback to display, I don’t it works with pass-through; and set adjust framerate to always or start stop.

Thanks Tom.


#5

Disabling “Sync playback to display” did it. Now I have DD and DTS passthrough although sound seems to get silent from time to time now and at some point during the playback sound directly stops and a lot of loud static noise.

Regards.


#6

Just to add more information, the “pauses” in the sound seems to be that the signal is interrupted and not getting to the receiver (the receiver DTS or DD display flickers and stops to detect the correct signal). After a few minutes and a few pauses, the sound stops and all I get is loud noise.


#7

Hi,

Can’t really advise on this as I don’t have a hifiberry digi+, but similar issues reported here:

I would try disabling mmal under hardware acceleration and see if that helps.

Thanks Tom.


#8

Hi Tom, it seems I am having a very similar issue like the post you just quoted. I have this “(the image is fine, just the sound that stops for a second or two, sometimes less, and then comes back)”. And then, eventually after a few minutes the full signal gets lost and i get only noise. It seems to be only a passthrough issue and disabling MMAL would not allow me to do passthrough so that fix won’t work to me. Will try to upload logs once I get home.

Regards.


#9

Hi,

Could you also provide screen shot of your audio settings, I’m not sure what is going on; but you seem to be describing a problem which was solved back in 2016:

Thanks Tom.


#10

Sure, will play a DTS and DD video with the problem and send full logs and screenshot of the audio settings as soon as I get home.

Thanks.


#11

Try turning off stereo upmix, eac3 passthrough and Keep audio device alive