No flac playback from library

I’ve just started using OSMC on a Raspberry Pi with music in flac on an attached USB stick. I’ve added the location so I can see the album/artist/song classifications. If I play from these locations it doesn’t play, then gives an unable to play error. If I play via the file structure then it works fine.
What am I doing wrong?

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

OK, so I was hoping as a beginner I was doing something obviously wrong.
I enabled debugging and uploaded following the instructions:
But this looks blank?

Looks like something went wrong there. Try uploading logs again.

If still blank, SSH in and do grab-logs -A from command line. Maybe it’s throwing an error message.

Okay. Now I see that I have to select the logs required first. Which ones do I need because if I select all then it says ‘document exceeds maximum length’

Reboot twice so that log and old log are both cleared out. Then enable debug and produce the problem and create log.

Thank you. Try this :

Does anyone have any ideas about this?

It seems you are not on the latest OSMC update, so suggest you are installing that first to avoid any issue caused by an older version.
Other than that I only can see failures to play 1.flac, was there anytime that you played 1.flac successful via “files” during this logfile duration?

I didn’t try to play it via files in this session because I was trying to keep the log clean, but it has always been successful that way, and always unsuccessful via album or artist categories.
Why would it not play 1.flac?
Thanks for the heads up about the upgrade.