No frontend was attached by 'Hauppauge Nova-T Stick'


#1

Hi all,

I have an old ‘Hauppauge Nova-T Stick’ (2040:7060) and I can’t make it work with my osmc running un RPi2. It is recognized, the firmware downloaded successfully, however the frontend is not created.

The current kernel is:
Linux rpi2 4.14.78-4-osmc #1 SMP PREEMPT Wed Dec 12 17:58:11 UTC 2018 armv7l GNU/Linux

[ 5.028040] dvb-usb: found a ‘Hauppauge Nova-T Stick’ in cold state, will try to load a firmware
[ 5.078927] dvb-usb: downloading firmware from file ‘dvb-usb-dib0700-1.20.fw’
[ 5.163504] RTL871X: rtw_ndev_init(wlan0)
[ 5.165178] usbcore: registered new interface driver rtl8812au
[ 5.165190] RTL871X: module init ret=0
[ 5.202186] dib0700: firmware started successfully.
[ 5.562461] lirc_rpi: auto-detected active low receiver on GPIO pin 18
[ 5.562828] lirc_rpi lirc_rpi: lirc_dev: driver lirc_rpi registered at minor = 0
[ 5.562838] lirc_rpi: driver registered!
[ 5.712748] dvb-usb: found a ‘Hauppauge Nova-T Stick’ in warm state.
[ 5.713096] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 5.714233] dvbdev: DVB: registering new adapter (Hauppauge Nova-T Stick)
[ 5.740238] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[ 5.944926] input: lircd as /devices/virtual/input/input0
[ 6.011042] dvb-usb: no frontend was attached by ‘Hauppauge Nova-T Stick’
[ 6.082512] Registered IR keymap rc-dib0700-rc5
[ 6.083217] rc rc0: IR-receiver inside an USB DVB receiver as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/rc/rc0
[ 6.083529] input: IR-receiver inside an USB DVB receiver as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/rc/rc0/input1
[ 6.084585] dvb-usb: schedule remote query interval to 50 msecs.
[ 6.084608] dvb-usb: Hauppauge Nova-T Stick successfully initialized and connected.
[ 6.087543] usbcore: registered new interface driver dvb_usb_dib0700

Any idea?


#2

What are you using to tune it? TVHeadend? Does it work?


#3

Nope. That’s the plan, but as the frontend is not created TVheadend is not recognizing the usb tuner, and so I can’t tune it.


#4

I don’t know what a frontend is, but Google dvb-usb: no frontend was attached by ‘Hauppauge Nova-T Stick’ and you will get some hits.


#5

Hi,

Well, long story short, when you plug a usb tuner some directories and files should be created on the /dev folder similar to these:>

$ ls -l /dev/dvb/adapter0/
total 0
crw-rw---- 1 root video 212, 1 Jan 11 19:02 demux0
crw-rw---- 1 root video 212, 2 Jan 11 19:02 dvr0
crw-rw---- 1 root video 212, 0 Jan 11 19:02 frontend0
crw-rw---- 1 root video 212, 3 Jan 11 19:02 net0

However, in my case the “frontend0” doesn’t get created and therefore the tuner doesn’t work. The other files are created, the only missing one is the frontend0.

Obviously I googled it alreday. I had no luck so far. In this old topic they mention something about unloading some kernel modules, but the post it’s so old, that those modules (ehci_hcd and uhci_hcd) doesn’t exist anymore in the kernel as the kernel usb section has changed dramatically since then.

Any other idea?


#6

Does it work with Raspbian? Or any other linux?


#7

I haven’t tried just yet. I will try to setup a raspbian environment and see if that helps.


#8

With some sticks, there are several versions of the firmware, even with the same filename. You might like to have a look for others.


#9

I’ve just tested it on a debian 9 stretch and it worked without a problem with exactly the same firmware I was trying yesterday:

md5sum dvb-usb-dib0700-1.20.fw
f42f86e2971fd994003186a055813237 dvb-usb-dib0700-1.20.fw

So, the problem must be somewhere else…


#10

I don’t have a great deal of experience of this kind of product, but in order to give us the best chance of sorting out your problem, we need logs, ideally a full set from OSMC.

Similarly, if it works on Debian stretch, then it’s going to help us if we can see (at least) the system journal from that box. Saying it works doesn’t give us much to go on.