No GUI WiFi or Bluetooth

New to OSMC and Kodi.
Installed OSMC image dated 5-1-2019 on RPi B+. Wired Internet. HDMI to TV monitor. USB mouse, which works. I have not configured a remote at this time.
When first installed, set interface for Kodi Classic. After first boot, that interface is gone and only OSMC interface is available. There are missing menu items to configure Kodi in the OSMC interface. Seems this is a common disappointment. I can get by with the limitations.
The real problem is WiFi. Using the OSMC menu, I was able to turn on WiFi and connect. I was also able to turn on Bluetooth and pair a keyboard. Worked fine.
All worked until a few days later an update was installed. It is showing up as Kodi 3.8-RC1 dated 5-19-2019.
At this time WiFi nor Bluetooth can be found on the OSMC menu System>Settings>Ststen>Internet access.
I have the webinterface Chorus2 running and connect just fine. The options to manage WiFi and BT are missing there too.
SSH is working, but don’t want to get into managing internet and devices via command line every time I relocate the RPi on a internet…
Any pointers on how to do this, I may not know where these setting may appear in the complex menu layout…
Thanks

Which model of Pi do you have?

The original B+ doesn’t have WiFi or BT

Sam

My mistake… RPi 3 B+

Norm

With all the odd problems, I’d suggest that you try a new installation on a new SD card. SD cards have a limited life and when they start to fail you will see strange problems.

SD cards do strange things…yes.

I initially installed on a 16G sd … that worked but then it did the same thing I’m describing, so I installed on a new 64G sd and got a repeat of symptoms. Fairly sure its not an sd problem.

The install went so smooth and things just worked. It recognized a HD with multimedia, played movies, displays slide show of slides; then added some TV series and watched a few perfect.

Thought I had my old Boxee Box back.

Norm

The WiFi and Bluetooth settings are found under MyOSMC.

Supply logs showing this happening. I’m not sure why you think this a common problem. The only issue like this lately was upgrading from V17 to V18 when you were using profiles.

I knew someone would thump me on the head and show me the light. Thank you. Changed skin to OSMC and sure enough there are those WiFi and BT options. wifi configured and connected. BT on and paired to keyboard, working.

I’ll stick with the osmc skin and get used to it. Just difficult to my eye for finding things. Part of it is the overscan of my tv display from the rpi… can’t see last bit the edges. Did the calibrate procedure and it helped, didn’t clear, so its my monitor’s problem.

I can now move on to getting a remote working, a mouse moving around the arm cushion of the easy chair … just isn’t cool.

Thank you for your help, time, and teachings.

Norm

Try this:

https://osmc.tv/store/product/osmc-remote-control/

Usually you don’t need to calibrate. Look for 1:1 pixel mapping or just scan option on your monitor.

Sam

Check your TV settings for something like ‘Just Scan’

You can use other skins. If you do, then MyOSMC will be under Programs for most skins.

Are you using a computer monitor instead of a regular TV? If so you could try using a different refresh rate (probably 60hz) and/or resolution in the display settings. Monitors do not normally overscan but some of them cannot properly handle some refresh rates or resolutions and will overscan when this occurs.

If you are using an actual TV then I would make sure the TV is not set to anything other than than a normal aspect ratio (most will let you change it to remove black bars). Ideally you would want it set to whatever your TV calls it 1:1 aspect ratio (ie no overscan at all). If you want to remove black bars you probably would want to do that in the pi instead of the TV which would only modify the video when it needed to and leave the menu screens unaffected.