No HDMI audio after update to OSMC 5.10.78

Hello

I lost HDMI audio after update to OSMC 5.10.18.
Video is OK, may need to tune buffering
I tried most of the suggested configuration items.

Linux osmc-kodi 5.10.78-5-osmc #1 SMP PREEMPT Mon Feb 28 00:17:33 UTC 2022 armv7l GNU/Linux

Raspberry Pi 3 Model B Plus Rev 1.3

/boot/config.txt

# Warning: do not edit this file, or it could prevent your OSMC system from starting.
# If you wish to make changes, you should do so via My OSMC or edit the config-user.txt file in this directory

# Any changes that you make here will be overwritten as this file is managed by the OSMC via the update system

[pi4]
dtoverlay=rpivid-v4l2
arm_64bit=1
kernel=kernel.img

[board-type=0x0e]
dtoverlay=vc4-fkms-v3d,cma-256

[all]
dtoverlay=vc4-fkms-v3d,cma-512
disable_overscan=1
start_x=1
disable_splash=1
disable_fw_kms_setup=1
hdmi_ignore_cec_init=1
include config-user.txt
dtparam=audio=on
dtoverlay=audio=on

[pi02]
dtoverlay=vc4-fkms-v3d,cma-256

I also have a debug log (if you need it)

Thanks

Hi,

This would be helpful.

Regards Tom.

  1. You should write your customization to config-user.txt
  2. dtparam=audio=on and dtoverlay=audio=on are only needed for Analog audio remove them if you use HDMI audio
  3. dtoverlay=audio=on doesn’t exists it would be dtoverlay=pisound but as mentioned this is not needed in your case
  4. dtoverlay=vc4-fkms-v3d,cma-512 is not suggested, so if removing the audio settings above and reboot doesn’t solve your issue first try with dtoverlay=vc4-kms-v3d,cma-512 before troubleshooting further.

Support Suggestion 1, remove audio configuration

  • Note: not needed for HDMI audio
  • Note: I connect the HDMI after power is applied
  • Note: my display detected: 1024 * 768 60Hz DVI (video OK)
  • Note: no HDMI audio
  • 2022060702-config.txt
  • 2022060702-config-user.txt
  • 2022060702.log
    Support Suggestion 2, change back to original config’s
  • Note: from: fkms to: kms
  • Note: no HDMI or DVI video
  • Note: no HDMI audio
  • 2022060703-config.txt
  • 2022060703-config-user.txt
  • 2022060703.log

Note: in all cases ssh was OK

Why did you do that?

That is a strange one, so what are you connected to?

Upload logs Either via MyOSMC Log Uploader or grab-logs -A

Hello
My setup is:
C1 = Dell Computer, Windows host, Ubuntu guest, for ssh
C2 = RPi 3B+, OSMC
C1—KVM—Display, Keyboard, Mouse
C2—KVM
All Display cables are HDMI, and HDMI connection on the Display
Note: this setup worked with the previous OSMC for HDMI video and audio
Display: INSIGNIA NS-24D510NA17

The log I am sending you is using the original configuration (as of updating OSMC).
Used the below, because of no display signal.
osmc@osmc-kodi:~$ grab-logs -A
Logs successfully uploaded.
Logs available at https://paste.osmc.tv/ecivubozew

I would suggest that you try without the KVM. KVMs try to play with EDID info and yours may be problematic. Trying without the KVM will rule that out.

Bypassing the KVM, fixed the HDMI video and audio.

But, it lost the USB external drive (was: /dev/sdb, now: /dev/sda)
Note: this was working last night
Note: drive is NTFS type

I then disabled my entry in /etc/fstab for the removable device, because OSMC would fail it and halt the boot.
This is the log path: https://paste.osmc.tv/nozisuleme