No hdmi signal on rpi3 after boot logo

Hello guys, I recently installed the latest version of OSMC on my RPi 3 B+ and having a problem with boot
OSMC is starting but I have no hdmi signal on my tv after logo and also it’s not connecting to my Wi-Fi so I can’t connect by SSH to fix that problem
Image written by OSMC Installer on SD Card

Have you tried on another display?

Yes, I tried a monitor on 1024x768 30hz(it’s pretty old, but I don’t have another one)
There’s still the same problem

I’ve downgraded OSMC to 2020 release tree
This version is working properly but after update problem is the same
But now I can connect by SSH
I grabbed full logs of the OSMC and can’t see the error

I grabbed logs from Kodi and found that he can’t load OpenSink which is probably causing these problems with the hdmi signal

Guys from the Kodi forum said that’s driver/hardware problem
But how it can happen on rpi3/rpi2 version of OSMC?
It’s optimized for rpi3/rpi2 only, right?

I fixed HDMI signal problem
Just changed the dtoverlay line in /boot/config.txt to:

dtoverlay=vc4-fkms-v3d, cma-512

There’s a new problem, with the CEC and HDMI audio
CEC is not working anymore with stock TV controller
Also HDMI audio is not working
Kodi blocked changing of the audio output device

This will be a temporary solution, I’m searching for alternatives

CEC absolutely dead in this solution.

I’ve fixed HDMI audio by adding into the /boot/config.txt this line:


I searching for way to fix CEC
I also will check how it’s playing media on this settings

CEC won’t work with fkms. The libcec with this version of OSMC is compiled to work with /dev/cec0 and only kms exposes CEC as that device.

If you want CEC to work then you have to go back to kms and fix the no HDMI signal problem some other way.

Perhaps you could try some settings in this thread: