No "/home/osmc/.xsession" file

When i start osmc i get a grey screen with this message, and also: “no session manager, no windows manager, and no terminal emulator found”…

OSMC does not use an Xorg window manager. This would seem to indicate that you have attempted to make some system changes?

I only tried to install a vnc server as explained on [HowTo] Install a vnc server on the Raspberry pi but it didn’t work so i made sudo apt-get install tightvncserver and now vnc works. Then i removed the /home/osmc/dispmanx_vnc-master/ directory.

And i also installed mc because i like to manage files with this tool.

This is all i made.

Another information: i tried sudo systemctl start mediacenter but nothing happened, no error message, the screen remains the same.

What makes you think tightvnc will work on OSMC ? There is no xwindows so only dispmanx versions of vnc can work, and not very well at that.

Have you tried properly uninstalling the packages you installed ??

If i’m not mistaken, tightvnc was working with raspbmc. If osmc is a system that doesn’t allow a correct vnc server, let me know, and i’ll install another distro.