No internet from OSMC wifi dongle

Hi. So I bought a couple 5ghz wifi dongles from the osmc store since I thought it would just be plug and play. But I’m having some problems. I can see my 5ghz wifi and connect to it but it does not connect to the internet. It gets an IP address just no connection. Connecting to a 2.4 wifi does the same thing, no internet. I’m using a raspberry pi 3 and have disabled the onboard wifi already. So any help would be appreciated. Thank you.

That sounds strange, how do you verify no internet? Are you just seeing that in Kodi?
Try to connect with SSH and run these commands and let us know the output:
ip addr
ip ro
cat /etc/resolv.conf

Yea, through kodi and nothing that requires internet connection works.

The 2.4ghz wifi connected while trying to ssh and had a very weak connection compared to when connected with the onboard wifi. But I’m using puTTY to ssh and put ip addr, it said command not found. Same with ip ro. Switched to the 5ghz but couldn’t connect to ssh.

Sorry but I Don’t know anything about using a terminal besides going over instructions and seeing what happens.

Try ifconfig and route instead.

osmc@Rpi3:~$ ifconfig
eth0 Link encap:Ethernet HWaddr b8:27:eb:2d:17:64
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:2528 (2.4 KiB) TX bytes:2528 (2.4 KiB)

wlan0 Link encap:Ethernet HWaddr 7c:dd:90:b7:68:36
inet addr: Bcast: Mask:
RX packets:91225 errors:0 dropped:14 overruns:0 frame:0
TX packets:43128 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:125402036 (119.5 MiB) TX bytes:3953870 (3.7 MiB)

osmc@Rpi3:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default UG 0 0 0 wlan0 * U 0 0 0 wlan0 * UH 0 0 0 wlan0

Thats with 2.4ghz wifi which is now able to connect. Still have no internet with the 5ghz. Also, was able to hook up one of the dongles with my raspberry pi 2 and was able to connect to the 5ghz wifi with no problem.

Have a look here, might be that the update has created some issues with some channels (or country setting)

So the country code isnt set on my rpi3 like in the thread you linked but running the commands that are in that thread did not set the country code.

osmc@RPi3:~$ iw reg getcountry 00: DFS-UNSET
    (2402 - 2472 @ 40), (6, 20), (N/A)
    (2457 - 2482 @ 40), (6, 20), (N/A), PASSIVE-SCAN
    (2474 - 2494 @ 20), (6, 20), (N/A), NO-OFDM, PASSIVE-SCAN
    (5170 - 5250 @ 160), (6, 20), (N/A), PASSIVE-SCAN
    (5250 - 5330 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
    (5490 - 5730 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
    (5735 - 5835 @ 80), (6, 20), (N/A), PASSIVE-SCAN
    (57240 - 63720 @ 2160), (N/A, 0), (N/A) 

osmc@RPi3:~$ iw reg set US command failed: Operation not permitted (-1)

tried the command sudo iw set <country code> but it just shows me a long list of commands I can do

I did change the channel to 40, 48 but still no internet. I even formatted my sd card to the March update since I noticed thats what is on my rpi2, just to see if it would work. Same issue.

You would need to do sudo iw reg set US

Well this would then indicate some issue with either your Wifi, the Pi or the dongle itself. Provide dmesg | paste-log maybe something can be seen

So I got an idea and grabbed the sd card from my raspberry pi 2 and stuck it in my rpi3. The 5ghz connected instantly. So the problem must be the sd card I had on my rpi3 since it’s one I just had laying around before I got the rpi3. I’m going to buy a new one and test it out. Thanks!